Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since I've upgraded to 4.0.3 my rooted Samsung Galaxy S2, Wi-Fi and/or 3G connections auto enable/disable.

I've found a similar question asked here: Wi-fi is auto-enabling

I'd be grateful if someone could find which of my apps is handling the connection:

share|improve this question

You've got quite a few apps in that list which can turn your connections on and off, and make other changes to your network settings.

If you have a look at the permissions the app has (either in the apps list on your phone, or by looking it up in the Play Store), you can see these permissions listed, for example if you go to the Battery Defender-Battery Saver apps Play Store Page, you can click the Permissions tab at the top of the description and amongst its permissions list you can see these:

change/intercept network settings and traffic
Allows the app to change network settings and to intercept and inspect all network traffic, for example to change the proxy and port of any APN. Malicious apps may monitor, redirect, or modify network packets without your knowledge.
change Wi-Fi state
Allows the app to connect to and disconnect from Wi-Fi access points, and to make changes to configured Wi-Fi networks.
change network connectivity
Allows the app to change the state of network connectivity.
Bluetooth administration
Allows the app to configure the local Bluetooth tablet, and to discover and pair with remote devices. Allows the app to configure the local Bluetooth phone, and to discover and pair with remote devices.

The easiest way to find the culprit would be to uninstall one of these apps, use your phone for a day or two and see if the problem happens. If your phone works ok without the app installed, then you've found the problem app. Whereas if your phone still has the problem, you can re-install the app you've removed and uninstall another one for a day or two.

It could also be that two or more apps are interacting or interfering with each other and causing the problem (one app may be trying to switch your wifi off to save power while another switches it on to do something else). If this is happening then the best way to work out which app is causing the problem would be to uninstall all of the apps that could possibly be causing the problem, then re-install them one at a time over a period of a few days, and watch to see when the problem starts happening again.

The easiest place for you to see all of the apps on your phone and click throught to see their permission is probably by going to your My Apps page in the Play Store where it shows all of your installed apps and you can quickly click through to the app's description and permissions pages.

Out of your apps list, the apps that look most likely to be causing the problem are these, but I haven't been through the permissions your apps are using one by one so it could be another that is causing the problems:

share|improve this answer
I can't find anywhere this "permissions tab"... – jasmines Aug 31 '12 at 11:05
Ok, found! I'll do as you suggested. But, is there an app that can do something like "no one can auto enable/disable wifi and data connection if they're manually setted as disabled"? – jasmines Aug 31 '12 at 12:11
Unless you're rooted I don't think there's any way that one app can stop another app from changing settings. They all have the same level of access to the same settings, they'd just end up continuously fighting each other turning the same settings on and off. – GAThrawn Aug 31 '12 at 12:54
My phone is rooted, as I said in the question. – jasmines Aug 31 '12 at 13:14
I found out the package is Battery Defender. Strange, but with 2.3 it didn't change network state automatically... – jasmines Sep 1 '12 at 19:45

Sprint added a new Connections Optimizer in the latest release. To disable this feature, go to: Settings > More > Mobile Networks > Connections optimizer > uncheck the box; mine says Sprint Connections Optimizer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.