Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Galaxy Mini powers on, but then hangs on the "Samsung Galaxy Mini" splash screen.

How can I re-install Android, or get it booting again?

share|improve this question
1  
Did you something that may have caused the hang? E.g. flashing some ROM? Or is there nothing special (just "normal use") you can remember? In either case, you could try a factory-reset. This would wipe all your apps and data, and make the device "virgin" again. – Izzy Sep 4 '12 at 22:13
    
I am having the same problem here. I didn't do anything special to trigger any problem. The phone just shut down on its own and when I try to boot it, it gets stuck forever on the "Samsung" splash screen. So, did you manage to solve your problem? – amine Oct 24 '14 at 15:37

Just found that solution and it worked for me! http://howtorootmobile.com/stuck-in-android-boot-loop-tips-to-fix-recover-from-boot-loop/

FYI my phone is not rooted, so I followed the first solution.

share|improve this answer
1  
Welcome to Android Enthusiasts! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Otherwise, your answer becomes useless in case the link dies. For further hints, please see: How do I write a good answer. – Izzy Oct 27 '14 at 10:26

You can fix it manly two ways. Performing a factory reset via stock recovery or flash stock firmware. Resetting is the easiest method. Press and hold power button, home and volume up keys until you see the Android robot logo. Stock recovery doesn't work touch screen you can use volume keys for navigation and power button /home key for selection.

Once you're in the recovery go to the "wipe user data" option via volume key and select that option via power key. Next choose "Yes" option.

Once it's complete you can reboot the phone via stock recovery. In recovery main menu choose "reboot" and select "yes".

share|improve this answer

Just had the same problem with Samsung Galaxy S III mini:

Steps I have tried:

  1. Do a "hard reboot" with long press of the Power button.

  2. Connect phone to the charger, then try to turn it on (that was the original problem: phone showed its logo, then turned black. Unfortunately after charging it it now hangs at the first boot-up screen (once it went as far as to the screen with "SAMSUNG" in it, i.e. the second screen; the third is usually operator logo).

  3. Remove the battery, press the Power button (with battery outside) to get rid of residual charge, then try to turn it on. Didn't work for me.

  4. Try to boot phone into "Safe Mode": press Power and Volume Down together for a while to do a hard reboot, then stop holding Power as soon as the phone turns on (vibrates). Didn't work for me, but it can supposedly cure the situation where last installed app was responsible for the hang-up.

  5. Go to "Recovery Mode" by holding Power + Home + Volume Up buttons together (you can stop holding Power button when phone vibrates) until you see the swirly Android logo. You should get a recovery mode menu, where you navigate with volume keys, and choose option with the power button.

    Here you can delete the /cache partition, then reboot phone. It did work, but it didn't helped me. It can supposedly cure the situation where the lack of disk space on this partition was responsible for the hang-up.

    I have tried steps 2-4 again.

  6. Reset phone to factory defaults from the same "Recovery Mode". This I have not tried yet (I'll try to recover data somehow... though most of my data is on microSD, and I have copied that already).

HTH.

share|improve this answer
    
Unfortunately, after trying to turn it on and do a adb backup, it completely stopped working -- all it shows is a black screen; no boot screen after long press of power button, no charging image when connected to the charger... – Jakub Narębski Jun 6 at 20:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.