Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have three devices:

  1. Tablet running Android 2.2; (WPAD)
  2. Tablet running Android ICS; (Samsung Tab 2)
  3. A laptop. (Dell Studio 1558)
  4. Wirelss Router: WRT120N (Linksys)

Wireless Router access is protected with WPA/WPA2 PSK. I can confirm that password given is correct.

My laptop (3) and Android ICS tablet (2), both connect fine to the wireless router.

But my other tablet (1) doesn't connect, it keeps "Scanning" and then disconnects. This tablet used to connect to router earlier, but now it does not. I have also observed that after a few seconds the wirless network is shown as "Not in Range, secured with WPA/WPA2 PSK" and then comes back with message "Remembered, secured with WPA/WPA2 PSK". So I am also not sure whether it is the problem with the tab!

Android ICS (2) is my new Samsung tab 2 tablet, so I have no idea whether this is caused due to new connection or not? To ascertain this, I have tried connecting only the first tablet (1), but still not working :(

The wireless router is connected to ADSL router provided by service provider. The ADSL router settings are password protected, i.e I cannot view ADSL router settings through web browswer.

Any thoughts on what could be causing the tablet to be losing the connection?

share|improve this question

migrated from superuser.com Sep 6 '12 at 16:13

This question came from our site for computer enthusiasts and power users.

    
Try changing the mode, channel, frequency and security. –  roxan Sep 6 '12 at 16:19
1  
Exactly what tabs are we talking about here? –  Al E. Sep 6 '12 at 16:27
    
@roxan: How and where do I change channel, frequency and security?. I have updated my post to mention that the ADSL router settings are password protected. I only have access to my wirless router. Do you mean these settings are of wireless router?. thanks. –  pradeeptp Sep 7 '12 at 1:01
    
Yes on wireless router. –  roxan Sep 7 '12 at 4:06
    
@roxan: Sorry for being dumb. I do not correctly understand what is channel, frequency and security. Could you please let me know what these settings should contain and to be set to ? –  pradeeptp Sep 7 '12 at 7:20

5 Answers 5

many Android 2.2 users report the same issue1. I'd recommend trying:

  • Delete the network from known list and then reconnect

AND/OR

  • Set a static IP address for your 2.2 device: wifi settings -> menu -> advanced -> use static IP (depending on your network config, submask to use: 255.255.255.0, default gateway (router IP): 192.168.1.1) to something like 192.168.1.200

--

1See the original authors: http://productforums.google.com/forum/#!topic/mobile/bbo7Y3CPOn8%5B1-25%5D

share|improve this answer
    
I have tried this settings but it is not working –  pradeeptp Sep 7 '12 at 1:23

I have resolved this issue myself. Here is what I did to resolve it:

  1. Accessed wireless router's settings. Please remember I do not have access to ADSL router which is connected to the internet.
  2. The linksys wireless router setting has "Wireless" menu. Under this menu, click on "Wireless MAC Filter".
  3. Click on "Enabled" radio button.
  4. Click on "Prevent listed computers from accessing the wireless network" radio button. I saw a list of MAC addressed in this list. One of the MAC addresses was that of the tablet which was not connecting. I removed this from this list and VOILA!!!! my tab was happy :)

(I still don't know how it got into this list!!)

share|improve this answer
    
Please mark the question as answered then –  Flow Sep 8 '12 at 17:02

Someone with access to that router may have accessed it through the internet just as you did and set up the MAC filtering. You have to manually enter every MAC address of every device that is running on your network in order to block just one MAC address or multiple addresses. Then you have to set what MAC address to block and save those settings just as you did to unblock your MAC address on that specific device.

share|improve this answer
1  
Your statements are very confusing. Please re-read it, and edit. Which ones should they block or unblock? –  geffchang Jan 11 '13 at 9:03

I have encountered this problem twice, once with my HTC Flyer, originally with Android OS 2.3, but somehow after I updated OS to Gingerbread the problem's gone. Second happened with my Google Nexus i515, running OS 4.04. Tried everything until i clicked Settings -> System -> Change wifi regulatory domain, and chose EMEA and Rest of World (the other options were US & Japan which weren't where I'm located) wifi settings resetted & problem's solved.

share|improve this answer

My Nexus 10 recently stopped connecting to the internet via WiFi after it had been connecting for 3 months. I simply rebooted off my wireless router by removing the power for 30-60 seconds and then powering up. Once the router rebooted, presto, my Nexus 10 was once again connected to the wireless network and the Internet.

share|improve this answer

protected by Community Feb 21 '13 at 3:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.