Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I want to disable the sound/vibrate effect when typing a message in Ice Cream Sandwich. I have disabled it in Settings > Sound Now there is no touch sound when I am typing a phone number or selecting an application to run, but there is still sound/vibrate when I type messages. How can I disable that too?

share|improve this question

2 Answers 2

up vote 6 down vote accepted

On vanilla Android you do this by going into Settings -> Language & Input and then pressing the settings button to the right side of "Android Keyboard" (or, generically, whatever keyboard you're using). There are two checkboxes on the keyboard settings page, one for "Vibrate on keypress" and one for "Sound on keypress". Uncheck both of these to disable the keyboard sounds/vibration.

share|improve this answer

To disable vibrate on the SwiftKey keyboard:

bring up keyboard
long-press Swiftkey/123 button
click Settings
Advanced
Typing Audio & Haptic Feedback
disable Haptic Feedback
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.