Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am struggling with this kind of Google Apps -site, example from Google.com -site here.

enter image description here

I use two email-clients in Android: default Gmail -client (because it is tied to my Gmail) and K9. I am able to set up all Gmails to K9 but one email i.e. the firm email from the site https://www.google.com/a/firm.com (excluding ofc the Android-tied-gmail -account, more here). It means that I am using K9 and default Gmail-Android -program but I would like to have all emails under K9. Is it possible and how can do it here in the case of the Gmails targeted to firms? I think such gmails are called something like Google App or something like that, not sure.

The firm Gmail is not accepted like this in K9:

Username: forname.surname

Password: correct

IMAP server: mail.myFirm.com

Security type: SSL (always)

Port: 993

Use compression on network: Mobile Wi-Fi Other

If I change the IMAP -server to mail.gmail.com, it gets accepted but it won't work correctly -- redirection problem. But now I am stucked why it does not accept the above settings?!

Perhaps useful to other like-minded

  1. All emails under K9 -app?

  2. Email-client with Sent emails from many emails under IMAP?

  3. Setting up IMAP over device-swarm that has a Debian Desktop -client, more here.

share|improve this question
    
...this issue is solved! –  hhh Sep 11 '12 at 23:33

1 Answer 1

up vote 4 down vote accepted

The default settings by K9 have at least two mistakes:

  1. use imap.gmail.com instead of mail.gmail.com.

  2. use full emails for usernames such as forname.surname@myFirm.com, not just forname.surname.

Example settings

Incoming Email settings

Username: forname.surname@myFirm.com

Password: correct

IMAP server: imap.gmail.com

Security type: SSL (always)

Port: 993

Use compression on network: Mobile Wi-Fi Other

Outgoing Email settings

Outgoing Server Name: smtp.gmail.com

Use Authentication: Yes

Use STARTTLS: Yes (some clients call this SSL)

Outgoing Server Port: 465 or 587

Username: forname.surname@myFirm.com

Some useful information extracted from this blog here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.