Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I understand that Cyanogenmod 10 is still in early access, but I installed a cm-10-20120910-NIGHTLY-i9100 build to my Samsung Galaxy S 2 anyways. I had a stock 4.0.4 before. I heard that this problem happened with previous CM versions, but couldn't find a fix.

Now, all my files are still on the internal SD card, but built-in apps like Play Music or Gallery can't see them. I can still access these files with PowerAmp or Root File Explorer. Even if I take a picture with the camera, it puts the file in DCIM\Camera where all the other pictures are, but it can only see the picture that I just took. There's no difference in file permission or owners between the files, all of them belong to system and group is sdcard_rw.

If I connect the device in USB storage mode, I can access all the files from my computer. In MTP mode, I can only see new files.

I tried to chmod 777 all files; it didn't work.

Does anyone know what I should do? Is there a way to tell android to see my files?

share|improve this question
Run Media Scanner.. – Evil Angel Sep 19 '12 at 9:08
Exact duplicate of… – pzkpfw Oct 19 '12 at 9:42

Happy to help. Here's a link to a solution that worked. Notable is the fact that this works for at least two devices that I have troubleshooted, so there's a high probability that this will work for you. While I didn't have the liberty of connecting my device (a Galaxy Nexus GSM) in the USB mode, I did see all my files in the MTP mode after doing everything exactly as it is detailed. All the best!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.