Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Lately I've been having trouble keeping a connection to Wi-Fi, first at home and now at work. What happens is that after a while I'll notice that my phone is using 3G.

If I go into my Wi-Fi settings, I'll see a strong signal from my router. When I try to connect manually, I often get the message, "Failed to connect to network" with no further details. (There's a special place in hell for those who write error messages that give no indication of the nature of the problem.) Other times I can connect, but the signal is reported as weak and drops quickly.

My computers can connect with no problems and report strong wireless signals. My roommates have no similar problems.

I have a Galaxy Nexus running Jelly Bean. My roommates have a Galaxy Note and a Galaxy S2, respectively, both on ICS.

What's wrong with my phone?

Additional details

  • My phone is rooted but running the stock ROM.
  • My phone is the international GSM version.
  • I first noticed this problem while using Tasker to implement a Bluetooth wireless leash. I've stopped using the leash--and Bluetooth entirely--but the problem persists. I'm still using Tasker for other things.
  • In trying to track down this issue, I disabled "Avoid poor connections" but that change had no effect.
  • I'm willing to consider flashing stuff to my phone as a last resort, but I strongly prefer alternative solutions. I didn't have problems initially, so I doubt the radio is to blame. Furthermore, I will down vote any answer that provides an incompatible ROM/radio, etc. or that provides it from a non-reputable source.
share|improve this question
    
Have you tried disabling "Avoid poor connections"? You can find this in Settings -> WiFi -> [overflow menu] -> Advanced -> Avoid poor connections. –  onik Sep 13 '12 at 10:24
    
I disabled "Avoid poor connections" a while ago to no effect. –  Scott Severance Sep 13 '12 at 13:24
    
If I were you, I'd uninstall tasker. This isn't as painful as it sounds, since you can have it back up all your settings, and restore them once you've reinstalled. –  offby1 Sep 13 '12 at 16:02
    
I've had similar issues and went as far replacing my AP which appeared to work at first, but then WiFI was bad again. The franco kernel appears to have some fixes for this. I used his app play.google.com/store/apps/… to update my stock kernel and so far so good –  Kendor Oct 2 '12 at 12:44

3 Answers 3

There are newer radios out there that greatly improve the radios. https://dl.dropbox.com/u/19045917/411_radios.zip Since you are rooted I assume you know how to flash radios.

share|improve this answer
    
Thanks for the answer. However, I don't generally flash stuff on my phone (you can't assume that rooting equals flashing stuff) I'm concerned about breaking things, especially when it comes to some random zip file posted by some random person with no details about what it does or mention of its official source. If you fix your post, I'll remove my down vote. –  Scott Severance Sep 18 '12 at 21:58
    
Upon further inspection of the radio ZIP file, I discovered that it isn't even compatible with my phone. Had I tried to flash it, it likely would have bricked my phone. –  Scott Severance Sep 18 '12 at 23:10

Three things that springs to mind

  1. Channel number of the Wifi's broadcast for the SSID (the identifier of the wifi network), try changing it to another channel?
  2. Wifi Sleep policy, go into Settings > Wifi, hit menu, tap on Advanced, Keep Wifi on during sleep, set that to 'Never'
  3. Lease time on the dhcp's IP address, there's a persistent bug in the wifi driver (well it existed in GB) if the lease time is set to -1 (which is standard de-facto for "unlimited"), the wifi mechanism within the ROM has difficulty in understanding that -1 i.e. negative number for the lease time, which results in similar problems with connecting to the Wifi. Try setting the lease time to a positive range, eg, 7200 seconds, or 2 hours and see what happens.
share|improve this answer
    
For number 1, do you mean to change the channel on the wifi router or on my phone? It's a shared router, so I don't want to break wifi for everyone else. –  Scott Severance Sep 18 '12 at 23:42
    
For number 2, I don't understand how the wifi sleep policy can have any effect since the dropout often happens while I'm actively using my phone. Am I overlooking something? –  Scott Severance Sep 18 '12 at 23:44
    
For number 3, I'll look into it, but I'm not too confident since the router configuration is presumably in a language I don't understand. –  Scott Severance Sep 18 '12 at 23:45
    
To answer the first comment, sometimes, wifi chips can have difficulty connecting, channel 6 and 9 can be a problem, its no problem with PC's laptops, as they obviously have more wifi "support". For number 2, when the handset goes to sleep, the connection drops, by setting it to never, the handset's wifi chip periodically "pings" to ensure the connectivity is there. –  t0mm13b Sep 18 '12 at 23:58
    
My router doesn't appear to have options to let me set the channel or modify the DHCP settings (it seems to be rather bare bones). I've set my phone to use a static IP, as that seems to be the closest I can come. We'll see how that works. Regarding number 2, my phone is set to disable wifi when the phone is asleep to save the battery. I don't think changing this setting will have any effect as the connection drops while the phone is awake, which means that wifi isn't getting disabled by that setting. –  Scott Severance Sep 19 '12 at 8:25
up vote 3 down vote accepted

My solution, which seems to be working so far, is quite related to what was proposed by t0mm13b.

That proposal was to adjust the DHCP settings. However, my router is quite limited in functionality and it's impossible to adjust wifi settings on it. Insane, I know. So, I set my phone to use a static IP address instead of using DHCP. So far, so good.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.