Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My Samsung Galaxy S running a CM 10 nightly opens the "Voice Dialer" application when i push the "call" button on my car radio head unit. Both are connected via Bluetooth.

As you might expect the Google Now voice recognition is far superior.

Is there a way to:

  1. Open Google Now when i press the call button
  2. Also use the cars microphone for voice input

Thanks for your help!


Edit

I believe the issue is similar or the same as this http://code.google.com/p/android/issues/detail?id=38566 Unfortunately Google has only given it Priority-Medium.

share|improve this question
add comment

3 Answers 3

Go into settings -> apps and click all. Then find voice dialer and disable it. That should disable the voice dialer app and Google Now should come up when you press the call button. If that doesn't work you can always reenable voice dialer.

share|improve this answer
    
I Disabled "Voice Dialer" and tried again. This time another interface was shown titled "google voice dial". From the quality of voice recognition and its TTS sound its just another frontend for whats behind the "Voice Dialer". Google Now did not show. –  ThomasS Sep 20 '12 at 19:22
    
@ThomasS I'm not sure if this would work, but you can try finding Voice Dialer in Settings -> Apps and tap on Clear defaults –  KevinOrr Mar 26 '13 at 16:33
1  
I can't even see 'Google Voice Dial' in my list of apps. Does it have a different name in 4.3? –  James Sep 8 '13 at 13:37
add comment

I was searching for a fix to this exact problem and came across your post. I just found this. I remembered your thread and thought i would come back to share this with you.

The guide says to:

Open Bluetooth Launch and scroll down to “Voice Search”. Tap on it to expand it out, then select: “com.google.android.voicesearch.RecognitionActivity”

but i found it in "Google Search" and then selected "com.google.andoid.googlequicksearchbox.VoiceSearchActivity"

I've got a galaxy nexus on Jelly Bean, which may explain the file tree differences.

Anyways, it works like a charm. Good Luck

share|improve this answer
    
The page states that on android 4.1.1 (which probably means 4.2.1) the software "Bluetooth Launch" can not be used anymore. Can you confirm this claim is wrong? –  ThomasS Dec 21 '12 at 8:10
    
Bluetooth Launch with the above configuration works for me on a Galaxy Nexus as of today. –  Earl Feb 6 at 5:14
add comment

I'm not sure if this is true for other phones listed above, but for The Galaxy Note II, I had to make sure S-Voice was disabled (it says Voice Dialer on the first post).

Also, if you have downloaded bluetooth launcher you probably already tried:

"Google Search" and then selected "com.google.android.googlequicksearchbox.VoiceSearchActivity"

and was still launching S-Voice. Once you disable S Voice (note the space) go into Settings > Application manager and scroll to the right to ALL. Then find S Voice and disable it.

Once you disable it and hit the button on the paired bluetooth device, you will get a "Complete Action Using" dialog. Resist the temptation to choose Google search. I know it's the logical choice, however you will not get Google Now; you will get a Google voice dialer instead. So make sure you choose "Bluetooth Launch" and select ALWAYS. Now when you hit the bluetooth button, you should get Google Now.

Note this will only work for the bluetooth. I had to use a separate app (Home2 Shortcut) for the double tap on the the HOME button.

  1. Go to the Google Play Store, and download the Home2 Shortcut app
  2. Open Home2 Shortcut
  3. Choose "Google Voice Search"
  4. Choose the speed that you would like to double tap thee home button (I left mine at NORMAL)
  5. Choose "TouchWiz home" for home application if you have the default launcher. If using something else chose that one; in my case I was using NOVA Launcher.
  6. Scroll down to the CLOSE button and click it.
  7. Double tap the HOME button. You should now get a "Complete Action Using" dialog.
  8. Choose Home2 Shortcut and select ALWAYS. You're done!

FYI: I don't think it matters but I'm rooted with a basic stock ROM. Again, these were the steps for me on a Galaxy Note II (Sprint).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.