Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use the hotspot feature on my HTC One X alot for connecting to the internet with my laptop. It's worked fine for months, but all of a sudden the last two days, the hotspot just stops for no reason that I can discern. I have restarted my phone and haven't installed any news apps recently. Any ideas?

share|improve this question
up vote 5 down vote accepted

You most likely have a hotspot timeout setting enabled.

You can disable it by going to your Advanced Hotspot Settings, and editing the timeout value to never.

Note that in some versions of Android in order to access the Advanced Hotspot Settings you need to first access the WiFi Hotspot Settings and then press the phone's Menu button.

share|improve this answer
    
Thanks for that, this was the issue. Never noticed the Advanced tab for this! – Wil Feb 4 '13 at 17:52

Just a note for others out there, the setting is not very easy to find (at least on my Samsung Galaxy S3 mini Android 4.1.1).

Go to Wireless and network -> More settings... -> Tethering and portable hotspot -> Portable WiFi hotspot. Once there, you'll have to press the Menu button (bottom left of your phone) and up pops Timeout settings!

One can only guess why they decided to hide that setting in such a hard-to-find place....

share|improve this answer
    
Any idea where this could be found on a OnePlus2? I would like to turn this feature on. – David Mar 1 at 8:02

I had the same problem. And then I realized that I'd set up Tasker to turn the hotspot off if it detected my favorite wifi network nearby. I've since removed that Tasker option, and the hotspot has stayed on.

I did not simply forget about the Tasker setting. Rather, even when I was nowhere near my favorite wifi networks, the hotspot would turn off. Tasker needs to briefly turn on the phone's wifi every so often, in order to see if it's near my favorite wifi network, and in so doing, it must also turn off the hotspot; my guess is that, somehow, it was unable to turn the hotspot back on after it shut wifi down.

share|improve this answer
    
Thanks for the reply, unfortunately I am not running tasker. Glad you were able to figure it out though! – Wil Sep 19 '12 at 15:37

Try calling your service provider. I had the same problem and upon making the call discovered that the company had some weird stipulation on my "unlimited" data plan that didn't allow for the hot spot without first paying a fee. Maybe there was a change in your service that weren't informed of

share|improve this answer

The fix is simple: Got to the setting in your device that is called: "Data enabled (Enable data access over Mobile network)" UN-check it OFF, wait about 30 seconds, then RE-check it ON.

You will notice then within 10 seconds the 4g will re-appear, and turn a beautiful blue - which means all good and working.

Works everytime.

On Verizon, you will need to do this every 2 to 3 hours. Why? Because that's how Verizon does it. T-Mobile does NOT create this restriction.

Also, you will notice that MOST devices wil NOT charge the battery when data is being DOWNloaded/streamed, so be ready for that.

share|improve this answer

There is also another possibility I installed a program named Du Speed Buster and it turn off hotspot in order to boost the system speed I had to unmark that to solve the problem check all of your programs, because it can be some program like it

share|improve this answer
    
That's the curse of auto-taskkillers: too many negative side-effects. – Izzy Dec 20 '14 at 14:24

Maybe my phone does not have any option to prevent this, I cannot find any "Timeout settings" for wifi-hotspot of my android phone. I have found an alternative solution:

1. I turn off the security(pattern lock/password etc.) when I use wifi-hotspot and it works fine. For all the android mobile it should work I think: Go to "Settings" -> "Security" -> "Screen Lock" (you may have to enter existing pattern or password for the lock) and set security to "None".

2. Also set the sleep duration to a low number such as 2 minutes or 15 seconds etc. To change the sleep duration go to "Settings" -> "Display" -> "Sleep".

After this your mobile will hopefully not stop wifi-hotspot when it goes to sleep mode.

When you have done with your work Enable the security again later by going to the same menu and setting security to "Pattern Lock" or anything you need. And you can also change the sleep settings as you like.

I have faced this problem with my android phone that I am currently using. This solution works perfectly for my phone and I found this solution myself finding no solution in internet. Then I shared the solution here in stackoverflow.

My recent findings is that, maybe the second step(mentioned above) alone can also do the trick.

share|improve this answer
    
Which Android device and version did you use to test this answer? I'm aware that when the device goes to sleep, a particular Wi-Fi setting can cause disconnection but I didn't hear about this being an issue with hotspot. – Firelord Mar 22 at 5:58
    
Yes my phone has this issue, it does not stop wifi hotspot but the connected devices don't get any internet from the hotspot, they are being blocked probably. I am using Sony Ericsson Xperia Arc S. Android version 4.0.4. Thanks. – Wasiq Mar 24 at 6:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.