Sign up ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I just unboxed a nexus 7 and coming from an iPhone I am missing the possibility to set multiple input languages for the on screen keyboard.

I need to type text in English and in Italian but I can't find a way to select the Italian keyboard. I am using a device bought in the US, but I don't think that would matter too much.

share|improve this question

5 Answers 5

up vote 6 down vote accepted

Assuming that it hasn't changed since ICS, you can go to:

Settings → Language & Input → Android Keyboard settings

You can enable another languages over there and then you can quickly switch by long pressing on the space bar or by tapping on "Select input method" entry on the Notification Bar.

share|improve this answer
Thanks it was still there. I looked at that menu but it was missing the latest step – mariosangiorgio Sep 21 '12 at 3:37

If you want to be able to write in multiple languages without having to change the language of the keyboard all the time, you have to use a third party keyboard like SwiftKey.

With Swiftkey, for example, you can start writing in english, write some text in italian, and continue in english, without having to change anything.

share|improve this answer

For Android 4.4:

  • Go to Settings, Language & input, and scroll down to KEYBOARD & INPUT METHODS.
  • Click on the dial icon next to Android Keyboard (AOSP)
  • Click on the first entry Input languages
  • Untick Use system language
  • Tick the languages that you want

Now you can switch between keyboards by long-pressing on the spacebar.

share|improve this answer

On 4.4.4,Long press of the key to the left of the space bar, setup input methods then untick use system language, you can then choose your languages.

share|improve this answer
I guess the OP wants both english and italian simultaneously. – ce4 Dec 10 '14 at 13:54

You have to uncheck the box that says "use system language". I had the same problem, I had not seen that!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.