Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have tried the suggestions here and here with no results.

Google suggest changing back to @googlemail.com, waiting two days and restarting the phone, but that hasn't worked either.

Anyone had any luck with this?

share|improve this question
    
Good question! I want an answer to this, lots of people having the same problem: google.com/support/forum/p/Talk/… –  Dan Nov 28 '10 at 19:55
    
May be silly question, but have you logged your phone in with the new @gmail account? I went through this grief a while back... I'm racking my brains to remember how I got past it - will let you know as soon as I do! –  FoleyIsGood Nov 29 '10 at 23:15
    
@foleyisgood: Thanks, but yeah I had tried that. Jim posted the 'solution' that I ended up using below. –  billynomates Dec 13 '10 at 10:47
add comment

1 Answer

up vote 2 down vote accepted

I had this issue with my old G1. The only resolution I was able to find was to do a factory reset on the phone and re-enter the Google ID with the @gmail.com extension, as OS version I was running does not have the ability to remove your Google account.

Newer OS versions do seem to have the ability to remove your Google account from the phone and re-enter it with the new extension as I've been able to do this on Froyo at least.

share|improve this answer
    
Yeah, this is exactly what I ended up doing. It's a real shame it has to come to this though! –  billynomates Dec 13 '10 at 10:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.