Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

This question already has an answer here:

Note: there is a related question to this, however it has no definitive answer. Asking in case anyone has discovered any solutions in the intervening period.

Onavo count continually reports that Google Services is hogging my data. This seems a recent phenomenon - last few months or so. I've switched off background sync and tried to restrict to wifi only. All unsuccessful. It continues to use

Phone is HTC desire Z running standard Android 2.3.3 (HTC Sense 2.1).

Phone was bought outright (i.e. not included as part of contract), running on SIM-only contract from O2 in UK.

Any suggestions for what's causing this? And more pertinently, how to stop it?

Thanks.

share|improve this question

marked as duplicate by Al E., roxan, t0mm13b, ce4, Zuul Jul 25 '13 at 10:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
What do you mean by "Google Services"? Please include more information. –  bigbadonk420 Sep 25 '12 at 12:26
    
@bigbadonk420: Onavo simply reports it as "Google Services". It's listed under Settings->Applications->Running Services under the same name: contains 1 Service ("Google Messaging Service" and one process (com.google.process.gapps). –  sfinnie Sep 25 '12 at 12:37
    
I guess OP means things like the GTalk service, which simply ignore sync/bgdata settings (and even "no network", as I saw in my logs just yesterday: GTalk reported an HTTP error when I was in Airplane mode for at least half an hour already, with even sync and data explicitly disabled). –  Izzy Sep 25 '12 at 12:57
    
Rather than creating a duplicate question, you should post a bounty on the original so that it gets more attention. –  Al E. Jul 24 '13 at 13:46
    
show 1 more comment

1 Answer 1

Go To Settings> Accounts > Google > Click on Your Email/google account > Untick to disable any syncs that you don't need (eg: i dont need google play movies or bookmarks) > Turn off your device > take battery out > leave for 10 minutes > reconnect battery & turn on Your device > should be refreshed and ready to go with google services using less battery usage

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.