Sign up ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am using Android ICS x86 build for debug purposes in VMware Workstation, but I can't find any ssh server, so how can I install ssh server on it? I've tried SSHDroid, Dropbear SSH and some others - all they doesn't work, because they request ARM architecture.

share|improve this question
You are likely going to need OpenSSH, ported to ICS x86. Someone may already have tried this. See: – david6 Nov 10 '12 at 10:27
Dropbear SSH is FOSS. You should be able to generate a IA32 binary from the source and run it under android-x86. – Flow Sep 21 '13 at 12:46

1 Answer 1

You can have a look at Servers Ultimate on Play. The SSH server itself works on all devices and command line works on ARM and x86.

share|improve this answer
Thanks! Servers Ultimate is the only SSH server that works for me on Android x86 emulator – Alfishe Feb 20 at 15:37
Not working on my Android 5.1. Possibly due to 64-bit platform. – Sopalajo de Arrierez Sep 15 at 18:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.