Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I just got a Galaxy S II which I upgraded to ICS.

I really struggle with the battery life.

I have been looking around a lot on the forums explaining how to save my precious battery.

I have done quite a lot of testing, disabled all energy consuming widgets ... still I cannot get 10 hours of battery life (best case scenario without using the phone at all).

I have pushed the testing further by disabling WiFi, 3G and even switching to flight mode to reduce the consumption. I have also killed all apps (except Battery Monitor).

I haven't touched the phone for 4 hours (leaving it in sleep mode). During these 4 hours the phone has drained 40% of battery. The battery app didn't show anything suspicious.

When I do use the phone normaly (phone call, text, a bit of WiFi) the consumption is obviously a bit higher.

I am not quite sure what should be my next step:

  • factory reset ?
  • uninstall every single app to find out if one of them is faulty
  • Change the battery
share|improve this question
2  
During your four hours in sleep mode, what did the batter stats page show as the thing eating your battery? –  Al E. Sep 27 '12 at 16:52
    
After checking for Al's suggestion, next logical step to recommend would be checking with e.g. BetterBatteryStats for wake locks. There must be some app keeping the device awake. –  Izzy Sep 27 '12 at 17:50
    
Note that, depending on the apps, killing apps often have the inverse effect on battery life as they may reload again soon after to check on syncing. Leaving an app running are sometimes more battery efficient than constantly reloading and killing apps. –  Lie Ryan Sep 27 '12 at 18:51
add comment

2 Answers 2

The Android Authority has a great article on ways to extend your battery life on the S2.

In my experience:

  • Live Wallpaper is a huge battery eater
  • When I'm at work my 3G signal is very weak inside the building, which completely kills my battery in about 4 hours. I've found that if I leave the Wi-Fi connected at work and at home, the phone won't constantly look for a 3G signal, thus saving my battery.
  • Turning down the screen brightness is also a big help

If you've tried all these suggestions with no improvement, you might consider trying JuiceDefender.

share|improve this answer
    
Thanks for this, The problem I have is that I am losing 40% of battery in 4 hours without anything enabled (WIFI 3G were off, screen was off, all apps were killed, the phone was even on plane mode). Basically the phone should have been doing absolutely nothing not even trying to reach for signal. I have no widget enabled a very plain wallpaper (should not make any difference anyway as the battery drains with the screen off) –  Pallando Sep 28 '12 at 9:39
add comment

Try factory reset, wipe off all the apps and then see. If the problem still persists then check if changing the battery helps

share|improve this answer
add comment

protected by Community Aug 2 '13 at 9:15

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.