Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a pay as you go Android phone. I only pay 10 dollars per 3 months (or something like that). That means that every cent counts before I run out of money.

I want this phone for emergency reasons only and for internet so I don't use it to call. Yet my money on the account still runs out. When I check my statement I see a lot of charges for few to as much as 30 cents. I use my internet when I'm connected to wifi only but I think I'm still getting charged for connecting through my 3g network.

Is there any way to disable the connection with the data plan so the only internet that will work is wifi? This way I will not get charged.

I have tried changing the apn under settings and with apps. My phone seems incapable of even doing that. I wonder if it's some scheme to get me to pay for data without me noticing. I would still prefer a solution that allows me to call and receive calls at all times since I might receive emergency calls or need to make them. .

Update I downloaded an app called easyswitch and it allowed me to disable the 3g network the problem is that it's a trial that lasts a week. if anyone knows a free app that will do it please let me know. I also rooted my phone but don't really want to install a whole new rom on it.

After using easy switch for a while i realized that it keeps allowing 3g sometimes (sometimes it doesnt) I dont know what its depended on maybe if my phone restarts the easy switch settings restart as well? I think i will just install a new rom.

share|improve this question

3 Answers 3

Dial *#*#4636#*#*

Go to Phone Information and click Disable Data Connection.

share|improve this answer
    
That does seem like it would work if only there be an option called disable data connection under phone information menu. It's a pretty interesting hack though, thanks. –  Xitcod13 Oct 2 '12 at 7:26
    
Thank you :-) @Xitcod13 –  Deadlock Oct 5 '12 at 11:47

"Data Roaming" just refers to using data when connected to a foreign network (i.e. not your providers "home network").

There should be another option available for "mobile network" or "mobile data" (the phrasing may differ between devices), as the following screenshot shows:

Network Settings

Look out for the red frame at the end. If you find something similar, remove the checkmark. If not, simply remove it everywhere where it sound similar. Remember which ones you removed, then enable them again one by one until you find the "evil doer".

share|improve this answer
    
There is no such option on my device. At least under wireless and networks settings. –  Xitcod13 Sep 30 '12 at 21:39
    
So maybe you add some screenshots to your question, so we don't have to guess so much? –  Izzy Sep 30 '12 at 21:59
    
I would but I can't install the driver on my pc for my phone because I have vista 64. And all apps that allow you to take screen shots require you to do that (at least to my knowledge) –  Xitcod13 Oct 2 '12 at 7:30
    
I never did that (maybe since my devices are all rooted). You could also check out apps like AirDroid or Remote Web Desktop, which would let you do this even wirelessly from your PCs browser. –  Izzy Oct 2 '12 at 7:34

You haven't mentioned what version of Android you're using.

In Android's settings, go to Wireless and Networks > Mobile Networks and uncheck the option to use Data.

You will still be able to use WiFi.

EDIT: As an alternative, get an app like APNDroid which effectively renames your mobile data APN (access point name), thereby disabling the data connection.

share|improve this answer
    
I'm using android 2.2 under mobile network settings I see: data roaming (unchecked as soon as I got the phone) data roaming guard (which is on) and system select (no idea what this is left it as default) –  Xitcod13 Sep 30 '12 at 8:53
    
The app you suggested switches the mobile data option to on as soon as I switch it to off. I only click the button once so it's not because I'm double clicking. I tried to do out multiple times and it always switches back :( –  Xitcod13 Sep 30 '12 at 22:11
1  
Have you tried others? In a pinch, manually edit your APN (after noting down the correct config) to something else - that will disable your mobile data connection. –  Sparx Oct 1 '12 at 5:49
    
Thank you. I will try doing that . Il –  Xitcod13 Oct 2 '12 at 7:37
    
Ok I have tried a lot of apps and none of them work. I also tried setting apn manually but there is no option like that in my settings (google says there is but my phone doesn't have it) –  Xitcod13 Oct 3 '12 at 2:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.