Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My Samsung Galaxy S3 has major Wi-Fi problems. It will connect to Wi-Fi for a few seconds, then it quits and won't connect to anything. It happens at home, work, or anywhere else with Wi-Fi. It's not the router. My laptop and other phone works fine with it.

If I turn off the Wi-Fi and then turn it back on again, it will work for a little while, but then, nothing, no connection to anything. I've researched the problem for days and seems like a lot of people are dealing with the same thing.

There are some supposed 'quick fixes' but none work for me. (dialing *#0011# on the phone to turn off power save mode, downloading a Wi-Fi Fixer app, doing a factory reset, trying to set a static IP - phone won't let me, and everything else, NOTHING WORKS!).

Is this a problem with the phone or the software? Do I need to exchange the phone for a different one?

I even called Samsung and they claimed that no one else has ever reported a problem with this, even though there are hundred and hundreds of posts online about the issue.

Is Samsung doing anything about this or should I just give up and get a different phone all together? By the way, it always says that I am connected to Wi-Fi. It just doesn't actually work.

I've read about having to set the router to G or N but I have no idea what the means or how to do it? And besides, why should I have to do that? Shouldn't the phone's wi-fi just work? And how would I do this G or N setting at work? Not gonna happen, so I'd be outta luck there.

So frustrating!!

share|improve this question
    
I guess there is some problem with the hardware... nothing to do with the software –  Terril Thomas Oct 1 '12 at 11:33
    
Strongly recommend looking at: android.stackexchange.com/questions/29291/… –  david6 Oct 2 '12 at 9:03
add comment

1 Answer 1

If you're using the Sprint version of the S3, see if Sprint Connections Optimizer is turned on under Settings > More Settings > Mobile Networks. Make sure it's turned off, as it can cause Wi-Fi to be a little funky sometimes.

share|improve this answer
    
The sprint connection optimizer is probably the worst most useless app of its kind. It is truly horrific. –  atroon Nov 17 '12 at 15:11
add comment

protected by Community Apr 14 '13 at 3:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.