Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I installed MadTeam's CyanogenMod 7 on my Galaxy 5 few weeks ago. First time I root and install a mod, but fairly uneventful process. My phone got way faster, and except for maybe getting a little slower to connect to the wifi and/or obtain an IP address, it is better in every possible aspect.

What is bugging me is that it is prone to restart itself randomly, possibly many times a day, except that I don't notice it most of the time. Just now I noticed because it was in front of my keyboard, and it vibrates when showing the boot animation. The boot itself is quite fast, so it really never posed any problem so far, and it never restarted mid-use, only when inside my pocket or laying on the table (ie. during standby). I just worry that it may become too common or happen during a call, while texting or something.

I fiddled a lot with the configs after installing it to discover what it had to offer, but I avoided changing anything that wasn't UI/usability-related. I took the performance settings warning seriously.

Any possible explanation? Or is this somehow normal, like a hard memory cleaning procedure? I did some seaching, but nothing about such issue.

  • Phone: Samsing GT-I5500 (Galaxy 5)
  • Mod: CyanogenMod-7-20120912-MADTEAM-galaxy5 (Android 2.3.7)

Updated mod to 20121001 version.

Got two unresponsive events (once unlocking screen and another one activating wifi) which caused phone restart seconds later, and according to phone uptime counter, an spontaneous reset 2AM last night. Within 48h.

Wifi got awfully bad after update (same baseband I5500LUYJPE), took dozens of tries to get an IP, but apparently it was solved by forgetting the network and typing the password again.

In short: wifi improved, random restarts remain.

share|improve this question
1  
Did you update the baseband as recommended to match your Galaxy 5? Some basebands are known to cause the sleep of death (I have one here!), boots up CM fine, then after a while, it goes to sleep and then completely dies which results in charging up the battery again. –  t0mm13b Oct 3 '12 at 16:19
    
@t0mm13b Yes, I changed it. After installing the mod, it was set to the stock ROM's baseband, I5500BVJJP7. I felt the wifi was bad (worse than now), so I followed the MadTeam devs suggestion and changed to I5500LUYJPE. The wifi improved somewhat, but I'm unsure if this baseband is responsible for this behavior, because I switched in less than an hour. I'll take a look about the SoD and see if it fits my case, and I might try the older baseband. Thanks! –  mdrg Oct 3 '12 at 17:05
    
Sometimes strange things happen when one forgets to wipe the Dalvik cache when first installing CM. As it doesn't hurt, you could try this (you should be able to do so from the recovery menu). That cleans up things, and the Dalvik cache will be rebuilt on the following boot (so don't wonder if that boot takes a bit longer than usual). –  Izzy Oct 3 '12 at 18:54
    
@Izzy Well, when installing I'm sure I did wiped the caches... twice. I could wipe it again, but I just found out that a new version of the mod was recently released, promising a SoD fix for some cases, plus better DHCP handling. I'll try it later today, and post whatever difference it makes. Thanks for your suggestion. –  mdrg Oct 3 '12 at 20:05
    
Could be good news. In case that solves your problem, I suggest you post the results as an answer. Crossing fingers! –  Izzy Oct 3 '12 at 21:13
add comment

1 Answer

up vote 0 down vote accepted

So, to avoid a hanging question:

Using the new ROM for almost two months. Tried the original stock baseband I5500BVJJP7 but it felt overall worse, so I went back to I5500LUYJPE. Now any issue is rare... it's weeks since I last noticed a random restart, my phone reports over 160h uptime (not 100% reliable, I've seen it not restart after a crash), and wifi is most of the time fast to get in IP.

In the end, as things improved with a new ROM, I suppose the issues are due to small quirks of the ROM itself. Should improve over time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.