Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have this weird problem with my Nexus 7:

When the WiFi network on the home router (AirTies) is set to WPA/WPA2 it is always stuck in the "login" phase and never actually connects to the network. The network icon shows that it continuously connects and disconnects.

Now if I switch the network to WPA2 only, the Nexus 7 connects fine. But then, a Mac on the same network keeps forgetting the network and I have to insert the key by hand every time it boots. Switching back to WPA/WPA2 simply reverses the problem.

I accept even suggestions to switch the ADSL/WiFi router, provided that you suggest one that you know works for both machines.

share|improve this question
2  
I've read about that phenomenon of some Androids having trouble in mixed WPA/WPA2 mode a couple of times now. As you described, people solved it by using either WPA or WPA2 (or even WEP). So WPA2 only you tried (but got trouble with your Mac). Any chances to pin it to only WPA? WEP would be a last-ressort, as it offers only marginal protection. –  Izzy Oct 5 '12 at 18:54
    
I switched to WEP until I buy a better WiFi/ADSL modem. Why not copy your comment as an answer, so that I can close it and give you the points? –  adamo Oct 7 '12 at 19:47
    
Done, and added another detail I just found. Not sure whether it helps you, but it might :) –  Izzy Oct 7 '12 at 20:14
add comment

1 Answer 1

up vote 1 down vote accepted

I've read about that phenomenon of some Androids having trouble in mixed WPA/WPA2 mode a couple of times now. As you described, people solved it by using either WPA or WPA2 (or even WEP).

So WPA2 only you tried (but got trouble with your Mac). Any chances to pin it to only WPA? WEP would be a last-ressort, as it offers only marginal protection.

Remark: Not sure about your settings for this, but in some cases people had SSID broadcast turned off on the router; turning it on again (i.e. broadcasting the SSID) solved the issue for some of them.

share|improve this answer
    
FWIW, I was broadcasting the SSID –  adamo Oct 8 '12 at 10:21
    
Thought so -- but also thought it couldn't hurt to mention this possible cause. Maybe for somebody else it's exactly what sheds the light :) –  Izzy Oct 8 '12 at 10:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.