Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I minimize the Android browser, it seems to forget what page it had open. What setting will make it remember?

Here are the steps I take. First, I load a website in the Android browser to completion, and then minimize the browser. At this point, if I press the menu button to see the apps that are running in the background, the preview still shows me the site open in the browser. When I select the browser, though, it comes up with the site about:blank (my home page) up.

This is under 4.1/Jelly Bean. When I had 4.0/Ice Cream Sandwich, this didn't occur. While searching, I came across a question asking for roughly the opposite behavior that suggested that memory might be the issue; in my case, there's plenty of RAM free, so that's not it.

I would prefer for the page to simply remain open, as it does when you minimize a browser on a desktop, but if the browser just remembered the URL and reloaded when it was brought back, that'd be okay, too. How can I set this up?

By "minimize," I may be referring to pressing the "home" button and opening another app, or pressing the "other running apps" button and selecting one of them. The device is a Galaxy Nexus.

share|improve this question
    
Not an answer (since you specified the Android Broswer) but a possible and (I find) effective work-around: I use Dolphin browser which does exactly this, even with multiple tabs. –  JRobert Oct 17 '12 at 13:22
    
How are you "minimizing" your browser? Are you pressing the back button? –  Raghd Hamzeh Oct 17 '12 at 22:05
    
@rnh16 Sometimes I press the home button and open a new app; other times I press the "other apps" button and select something else that's running. –  Pops Oct 17 '12 at 22:16
    
I just tried this on 3 Jellybean devices I had handy. Unfortunately all of them behaved normally, so I couldn't replicate your issue. Hopefully someone who had a similar experience might answer and provide the solution. Ideally, even if you have low RAM, Android would automatically "save" your browser state and automatically load it back into memory when you try accessing it again. - Side note: I suggest adding your device to the question, it may be a device issue. –  Raghd Hamzeh Oct 17 '12 at 22:25
    
@rnh16 Thanks, at least now I know that what I'm seeing is considered abnormal. (Before, I thought maybe it was just that the default behavior changed on Jelly Bean.) I've edited the question. –  Pops Oct 17 '12 at 23:07
add comment

1 Answer 1

up vote 2 down vote accepted

I had this same behaviour and figured it out. Go to Settings, Developer Options, scroll to the bottom and uncheck the Don't keep activities option. My Xoom didn'thave this sselected but my galaxy nexus did. Not sure if its a default or if I checked it accidentally at some point . Anyway, that solved it for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.