Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy S2 with CM10, I was testing SlimRom and notice that some applications that I bought on PlayStore showed the message "This app is not compatible with your device". It's the same device with different rom.

Any ideas about why this happen?

thanks!

share|improve this question
4  
I've had that before, I think it has something to do with how the device was named on the build.prop. I had a device that runs on ICS before, I changed rom to another ICS and one of my apps showed incompatible on the Play Store. I installed the app from a backup copy and it ran without problems. –  Propeller Oct 20 '12 at 4:00
    
@ShedoSurashu This is the correct answer, why not post it as such? –  Matt Oct 20 '12 at 16:33
    
Your best bet is to back up your apps prior to switching ROMs so you can install the app from your local backup and not rely on the Play Store. You can also modify your build.prop to fool the Play Store. –  Matt Oct 20 '12 at 16:35
    
Done! @Matt. :) –  Propeller Oct 20 '12 at 18:14

1 Answer 1

up vote 1 down vote accepted

I've had that before, I think it has something to do with how the device was named on the build.prop. I had a device that runs on ICS before, I changed rom to another ICS and one of my apps showed incompatible on the Play Store. I installed the app from a backup copy and it ran without problems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.