Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I know someone who bought a Galaxy Nexus recently, and he finally unboxed it today and straight away inserted the SIM and battery and plugged in to charge. Hours later when we tried to boot it for the first time, nothing happened. Removed and reinserted batteries, changed sockets, attached the USB charger to a PC, etc. but we still have no idea if the phone has charged or charging or if it's a completely defective item.

Please help me troubleshoot it.

share|improve this question
    
Take it back to the store. –  Al E. Oct 20 '12 at 18:10
    
@AlEverett I would love to. But there is wee little problem that there's no warranty. Technically there is, but it applies to a neighboring country. I suspect why we were able to buy it cheaply was because the 'other country's dealer' sold in bulk to 'this country', there were no warranty expenses. –  Oxwivi Oct 20 '12 at 19:04
    
If it's a grey market phone, usually the dealer will still take it back if you go back to him quickly. The cost of a phone is usually not worth the bad rep from selling defective items. –  Chinmay Kanchi Oct 20 '12 at 19:21
    
when it is plugged in does it give any indication that it is charging? i.e. screen comes on and shows battery image, or indicator LED above the screen comes on? If neither of these is happening I suspect the phone just isn't charging. Perhaps your USB cable or wall adapter is defective? –  FoamyGuy Oct 20 '12 at 19:58
    
@Tim This is my first Android phone, and there was no indication as you suggest. I thought this was normal as the quick start guide did not mention anything about that either (unless I need a new pair of glasses). But in any case, your conclusion is correct, but none of the things you suggest were the problems. I've answered myself, please check if interested. –  Oxwivi Oct 20 '12 at 20:26

1 Answer 1

up vote 3 down vote accepted

Okay, somehow or the other, I got it to work using tips gleaned from various links from Googling 'brand new Galaxy Nexus not booting'. I haven't figured out the issue, but I had the phone plugged in without the battery and inserting the battery then showed me battery charging image on the phone for the first time, but it quickly died out and I couldn't start the phone. After subtly pressuring the battery randomly, I got the charging screen back and switched it on.

Some of the posts in the aforementioned Googling suggested there might be slight defects in the Chinese-made Galaxy Nexuses (apparently it was made in both Korea and China), and mine is made in China. It might have to do with the battery not getting placed just right. I suggest to anyone facing similar issues to try to see if there's any effect with inserting the battery with the phone plugged in as I did in my case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.