Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

From the time the "low storage" warning appears no synchronization is done at all, including receiving SMS.

Can I do anything about it? Can I "force" my Motorola Milestone Froyo to receive SMS somehow?

This is really annoying. Especially because the user doesn't informed in detail. I missed a lot of SMS... I hope that gets fixed in Froyo.

share|improve this question
    
Did not get fixed in froyo. ;( –  OneWorld Nov 18 '11 at 9:26
    
Same question asked 1 year later android.stackexchange.com/questions/12275/… –  OneWorld Jan 5 '12 at 12:30
    
Google says, they fixed it in Android 2.3. code.google.com/p/android/issues/detail?id=4991#c257 –  OneWorld Jan 5 '12 at 12:41
add comment

3 Answers

up vote 2 down vote accepted

http://code.google.com/p/android/issues/detail?id=4991

This is bug. You must always make sure you have free space in Android, otherwise the bug might happened.

share|improve this answer
    
Thank you! While looking over the 400+ user comments at your link (and the linked issues there) I see I am not alone ;) –  OneWorld Jan 5 '12 at 12:12
add comment

SMS, etc. are stored on internal storage. If it's getting full, then you'll have to uninstall some apps to free up space to receive more messages. Not much else you can do about this.

My suggestion, however, is that you use an app like SMS Backup+ to backup your old SMS messages to a label in gmail. Then you can delete old threads which will free up space AND you'll still have a copy of all of your messages.

share|improve this answer
1  
Well, first of all I am not willing to seek the fault at the user. I know that this could have been developed way better. Motorola bound the SMS receiving process to the sync manager which is blocked when memory is low. That's the(ir) fault. SMS don't take much space and won't harm the system! Backing up SMS doesn't help, because the freed space is too tiny for the sync manager to recognize. That reminds me of times where only 10 SMS could be saved on a SIM. –  OneWorld Nov 30 '10 at 9:08
1  
I agree that more complete notification would be nice, but ultimately this seems 100% reasonable behavior to me. Your phone has some idea of how much space it needs to handle phone calls and otherwise function properly. If your phone doesn't think it has sufficient space to keep downloading data and still function properly, it should stop downloading new data. –  Amanda Mar 23 '11 at 14:23
add comment

If you don't mind losing older messages, most default messaging apps have an option somewhere in their settings (you'll have to look around depending on your device - I don't have a Milestone) and somewhere the should be a tickbox "Delete old messages" - tick that and set the limits and the phone will delete older messages, freeing up space (on the internal memory, as Bryan said) meaning you can receive more messages.
If you do need all your old messages, see Bryan's way

share|improve this answer
    
See my comment to Bryans answer. Deleting old SMS frees only very little space. The sync manager won't recognize it. It doesn't follow the basic logic of old fashioned phones, where you have a fixed and reserved storage for SMS. Thats why your suggested option doesn't have much impact ;( –  OneWorld Sep 25 '11 at 8:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.