Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

alt text

I always got this error when trying to connect my Galaxy S to my PC in Kies mode. I can connect it as "Mass storage" with no problem. But I need to connect with Kies mode to get 2.2 (froyo), but I always get this error. What is this error and how can I correct it?

I have Windows 7, Galaxy S 2.1, and kies already uploaded to the latest version. If this is of help, the PC tries to install "MTP USB Device" for a while (around 3-5 minutes) and during this time the phone shows a display that says "Initialising blah blah, press home to exit".

How to fix this? Or if this is possible, is there another way to upgrade to 2.2?

share|improve this question

10 Answers 10

First back up your data, all of it, internal and external SD memory. Then connect your phone to your PC choosing the Mass Storage option (first make it ask you before connect how to connect), then walk through all of your applications checking for any folder named cache or anything similar, then delete whatever is in it. If you came across any other kind of file that is cache or related to cache, delete it. This issue happens because some, most of them actually, cache files have a very long extension , and that prevents the MTP connection establishment. For me, I tried this in two ways, the first one, I formated my SD memory, both internal and external, and that didn't pay off, then I tried the method I mentioned above and it worked, if it didn't please reply telling so.

share|improve this answer
    
how can I back it up if I can't connect to PC? How do you know which file is related to cache and should be deleted? –  Fitri Dec 1 '10 at 16:59
    
back up all your contacts on your SD card, you can do so from settings or so. and there are lots of application in the market for backing up your contacts, texts and so. –  Omar Al Barahamtoshey Dec 1 '10 at 17:07
    
Connect in Mass Storage mode, copy all of your data on your PC, keep in mind that this won't back up your application or contacts it's merely for saving your files, then browse through your handset folders, cache files are located in folders called "cache", e.g. you have an application called XYZ, open its folder, most probably you'll find a folder called cache, delete the files from the cache folder. –  Omar Al Barahamtoshey Dec 1 '10 at 17:12
    
ok copied all folder called cache, and it didn't work. I even created a program that moves all files with filename length > 16 to outside of the SD card, and it still doesn't work. Do I need to remove long named folders too? –  Fitri Dec 2 '10 at 13:51
1  
sorry I tried removing all suspicous files but it doesn't work. However I found another way that work. Will post that as an answer –  Fitri Dec 5 '10 at 4:53
up vote 13 down vote accepted
  1. Go to Samsung Kies software, on top left of the window, click the menu > Driver recovery.
  2. Let it reinstall drivers
  3. After driver installation finished, go to your phone, Settings> Application > Development, tick USB debugging mode.
  4. Under USB debugging mode connect your phone to the PC with USB.
  5. It installs correctly!
  6. Disconnect from PC
  7. Untick USB debugging mode
  8. Connect again

and it works! Courtesy forum.ausdroid.net - USB not working (MTP restarting)

share|improve this answer
    
Thank you very much for sharing, but this SGS MTP thing is getting annoying, and there is several ways to fix it, yet there isn't a specific way to do it, what worked for me may not with for you, your way worked with my friend's handset and my way didn't :) –  Omar Al Barahamtoshey Dec 6 '10 at 0:17
    
yup. Thank you once again for your answer, unfortunately it didn't work for me :( I still upvoted it though –  Fitri Dec 6 '10 at 12:13
    
How do follow this process with the latest Kies software? btw and OT: this is my first android experience -- not fun –  CVertex Apr 5 '11 at 12:54
    
What worked for me was uninstalling the Windows 7 driver in device manager then reconnecting the device and letting the device driver reinstall. then kies sees the device - yay –  CVertex Apr 5 '11 at 13:01
  1. Uninstall Kies and all drivers, then reboot.

  2. Download and install the appropriate drivers from this XDA post.

  3. Download and install Kies Mini from Samsung.com (Support at the top, then just select your phone model and go to software).

  4. Connect your phone!

share|improve this answer

Found the problem to be like one of the guys said in another thread... it was the external SD having most likely unrecognized characters (at least to Samsung Kies) or characters that are too long... i removed the external SD and ran Kies and its working... might not be very useful to do it this way but I only needed it to update SW and manage contacts so its find :)

share|improve this answer

Resolved My Galaxy s connection problem on winxp 32bit by install this Microsoft_User-Mode_Driver_Framework_Install-v1.0-WinXP.exe

Edit: I think this has been replaced by the WDF. http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=36a2630f-5d56-43b5-b996-7633f2ec14ff

share|improve this answer

I have done a lot, including uninstalling Nokia-related phone apps, switching to debug mode and usb mass storage mode for getting different drivers. The 18 mb exe located in Samsung\Kies\USB Driver extracts many folders including .inf, but none is for MTP driver. The driver reinstalling option from Kies also doesn't help.

UNTIL

I switch back to the default home screen, not launcherpro, not HeLauncher, but TwLauncher, I get the 'MTP Application' screen on phone showing 'Connected' immediately. If this screen doesn't come up, it's impossible.

So my final piece of advice is to restore your phone to factory setting and see if it's a problem related to what you have in internal sd. (external sd removed of course)

share|improve this answer

No need for any backup or any formatting your SD cards .

all you need to do is just connect your phone , when it says failed go to device manager , uninstall it from there .

unplug your Phone , go to Kies , open tools > install drivers.

after installation plug your phone ..

only tested on Windows 7 x64 Ultimate .

share|improve this answer

I had the same problem with my device. A problem lied in the running apps that avoided the phone going to the standby mode (for me it was e.g. my K-9 email client).

Therefore, I shut these apps down, connected my phone again to my laptop and it was ok.

share|improve this answer

The hint from Omar proved to be the best for me. I found out that a wallpaper app installed long extension files in my SD card and I happened to find a sub-folder named "cache" inside the folder carrying the app´s name. Once I deleted it and reinserted the usb cable onto the phone, "voilá", the PC recognized it again on MTP mode!!

share|improve this answer

Try updating your windows media player to latest version.

share|improve this answer
1  
Does WMP come with MTP drivers for Android devices? –  Matthew Read Nov 24 '11 at 16:47

protected by Matthew Read Nov 24 '11 at 16:47

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.