Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had just installed custom ROM cynogenmod-9(ICS) in my S Plus device and now I am not able to add Google Account in my android device. It gives the following error message,

Couldn't finish
couldn't open connection to server.

So, what is the problem? why I am getting such kind of error?

share|improve this question
ahh, very messy :( – Azhar Shaikh Oct 29 '12 at 12:01
Is your Internet connection working in your phone? Did you try restarting your phone? – Suraj Bajaj Oct 29 '12 at 12:07
yes already tried that couple of times. – Lalit Poptani Oct 29 '12 at 12:08
up vote 1 down vote accepted

It seems that there was a network problem or gmail was blocked in my office which was making the server not respond and giving exception -> couldn't open connection to server.. I tried at home with my wifi and it worked finally.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.