Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a GSIII (Sprint) running Android 4.0.4. In the last three days, I have not made any changes or installed any new software that I know of, but my battery life has dropped such that my phone, when fully charged in the morning, now powers off sometime before I go to bed. This would make sense if I spent a lot of time using it, but I generally will check a few emails (every 20 min or so) and make maybe 4 calls of 5-10 min each in a typical day. I have not varied this pattern lately. I used to have to charge my phone maybe every other day, sometimes when really slow I could squeak 3 days out of it before charging.

Battery usage screen shows 'Cell Standby' taking up 40% of power usage. I hadn't been looking at battery usage lately, but it strikes me that when I first got the phone (3 months ago) I checked these a few times and Cell Standby was fairly low, around 10% as I recall.

I usually keep the phone on WiFi because of Sprint's crummy network, and the phone was in my house the entire time it was on battery, so was on WiFi for data...and WiFi takes up 3% of the total. Display takes up 2%.

I remember on my previous phone, the Evo (original) there was a Dialer bug that caused a wake-lock of some sort...I'm presuming something similar here. Several hard power cycles have not improved matters.

What do I do to stop it, or find out where the CPU cycles are going?

Edit: taking a look at the battery pane of the settings app reveals that the phone is staying awake 100 percent of the time that the radio is on. It did not used to do that. Putting the phone in airplane mode lets the phone sleep as usual except for a few times in three hours, as expected. So, apparently this is a wake lock condition again.

share|improve this question
    
Is your phone rooted? If so, use BetterBatteryStats. –  Chinmay Kanchi Nov 8 '12 at 10:53
    
Looking at your edit, this sounds like the infamous l2_hsic problem or something similar. This is a wakelock problem that occurs on the S2 and on the Note 1, but I'm not sure that the S3 has that specific problem. See: forum.xda-developers.com/showthread.php?t=1656705 for a documentation of the problem on the Note. Sounds awfully similar, doesn't it? –  Chinmay Kanchi Nov 8 '12 at 11:03
    
Wow, that is a great thread. This phone is not rooted, I could but it's against company policy. I am planning on an update to Jellybean in a couple days, I'll see if that contains any hope. –  atroon Nov 12 '12 at 17:52
1  
BetterBatteryStats should still work on an unrooted phone, though with reduced functionality. You could try installing it from the Play Store ($2.49) to see if you can see kernel wakelocks without root. There is also a free copy available (legally) from the developer, but that is really intended for those people who can't use the Play Store to buy apps, so I'm not going to link to it here. –  Chinmay Kanchi Nov 12 '12 at 18:41

3 Answers 3

up vote 8 down vote accepted

Cell standby being high means you have a really weak signal wherever your phone was. The phone cranks its radio up to maximum power to try to maintain a usable signal.

There are several ways to stop it - none of them ideal:

  • Put the phone somewhere with a better signal (near a window maybe)
  • Put it in airplane mode to turn off the radio (but you won't be able to get phone calls/texts)
  • Switch to a carrier that has a better signal near your home/workplace

As for why it's doing it now, it could be that you're leaving the phone in a different place in your house most of the time, or weather is affecting the signal strength, or sprint is extra crummy in your area lately.

share|improve this answer
    
I have very good coverage in one spot in the house. Leaving it there did not improve the situation. However, as noted above in my edit, it seems to be a wake lock. –  atroon Nov 3 '12 at 23:59

It could be an application keeping the phone awake. On my HTC Desire S I can click any application present in the Settings battery pane and see the time the application keeps the phone awake.

share|improve this answer

HERE ARE THE AREAS THAT EFFECT BATTERY LIFE - HOPE THIS MAY HELP

Weather Widget on front screen. - click to open -> Menu -> Setting -> Auto refresh = Every 3 hours

Then go to "Settings" (the lines in read are the Titles seen on the MAIN Settings screen most of which you can go in to and change more settings)

Wifi - Off when not in use

Bluetooth - Off when not in use.

Data Usage
Mobile Data = On
More Settings
Flight Mode - Off
S Beam = Off
Wifi Direct - Off
Near By device -> Switched Off
Mobile Networks -> Use Packet Date = On Data Roaming = Off

Sound (scroll Down to System)
Keytones = On
touch sound = On
Screen Lock Sound = On
Haptic Feedback = Off
Autp Haptic = Off

Display
Brightness - Open -> set to auto
Screen time out - After 30 Seconds
Smart Stay = On
Auto Rotate = On
Touch Key Light Duration = 1.5 Seconds
Screen Mode = Standard
Auto Adjust Screen Power = Ok
Display Battery Percentage = On

LED Indicator
Charging = On
Low Power = Off
Missed Event = On

Motion
Motion Activition = On
Direct Call = On
smart Alert = On Tap to Top = Off
Tilt to Zoon = Off
Pan to Move Icon = Off
Pan to Browse Images = Off
Shake to Update = On
Turn Over to Mute = On
Palm Swipe to Capture = On
Palm Touch to Mute = On

Power saving
CPU power Saving = On
Screen Power saving = On
Background colour = On
Turn off Haptic Feedback = On

Accounts and Sync
General toggle at top - ON Dropbox - No Sync
Google mail = Sync Then Open the option to display more
Sync Calendar = On
Sync Chrome = On
Sync Contact = On
Sync Gmail = On
Sync Google Phot = Off
Sync Google Play Books = On
Sync Google Play Movies = Off
Sync Google + = On
Sync Instant Upload = Off
Sync Internet = On
Sync Picasa Web Albums = Off
Facebook - Sync
Samsung account - No Sync
Skype - No sync

If you use Drop Box go in to the setting here and turn Upload using = WIFI ONLY

Location Services
Use Wireless Network = On
Use GPS = On
Use Sensor Aiding = Off (wasnt to sure what this was so left it off)
Location and Google Search = On

Security
Screen Lock = Pattern
With Swipe Lock = On
Lock Screen Option ->
Shortcuts = On
Information ticker = Off
Camera Quick Access = On (Might as well switch this off as I cant work out how to get by the Pattern Recognition for the camera to auto start)
Clock = On
Dual Clock = Off
Weather = On
Ripple Effect = On
Help text = On
Wake up in Samsung unlock = Off
Make Patterns Visable = On
Lock Auto = 5 Seconds
Lock Instantly on power key = On
Vibrate on Screen Tap = Off

Language and Input
Default = Samsung Keyboard
google voice type = Off
Samsung Keyboard = On -> in to Settings
Predictive text = On
continuous input = Off Keyboard Swipe = On
Handwritting = On Voice Input = GRAYED OUT Auto Caps = On
Auto Punctuation = On
Character Preview = On
Key Tap vibration = On
Key Tap sunbd = On
Voice Commands for Apps = Off

Acccessibility
Auto Rotate = On
Speak Passwords = Off
Screen Timeout = 30 Seconds
Lock Ato = 5 Seconds
Talk Back = Off
Install Webscript = Not Alloweed
Negative colours = Off

Developer mode - EVERYTHING IS OFF

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.