Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

ICS introduced an option to reject incoming calls with an SMS.

Is there a way to disable this function. If yes, how?

Sony Xperia S handset running JB

share|improve this question
    
Seems that there is no answer :( –  Sid Nov 9 '12 at 2:37
1  
I don't see that you can. It looks like, at best, you can change the possible responses to be empty fields. (Custom ROM solutions notwithstanding.) –  Al E. Dec 13 '12 at 14:28
1  
@Al Everett Well, it kindda solves the problem. But a message still gets sent. So the base problem remains as is. :( –  Sid Dec 13 '12 at 16:58
1  
@avirk Oh no!! So will there be an option to this in a future software update? Using a third party app call functions is not a good option for me. Thanks for the tip though. –  Sid Dec 14 '12 at 12:39
2  
@Sid it depends on feedback of user to their phone company. If most people find it annoying then may be they will or Google but not sure if any future update will do that. –  avirk Dec 14 '12 at 12:52

2 Answers 2

up vote 6 down vote accepted
+50

Unfortunately, there is no way to disable that. Sony is using a proprietary Dialer that has that function hard-coded into it. Without using a custom ROM, there is no way around it.

I know this because I have experience with this on Samsung devices (they also have a bar near the bottom that allows to Reject with Text), and having heavy proficiency with Android, outside of somehow recompiling the Dialer apk and using your knowledge of Java to find the entry, remove it, and recompile, there is unfortunately nothing you can do.

share|improve this answer
    
Thanks for the help :) –  Sid Dec 19 '12 at 2:29

Just go to Phone > Call Settings (Xperia Z3 go to Settings > Call > Reject call with message). There you'll see an option to "Reject Call with Message". Go there and you will see some template messages. Just delete all the messages one by one and that's it. Your problem is solved.

share|improve this answer

protected by Community Jun 26 '14 at 0:10

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.