Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

This happened all of a sudden. I could not start the 3g on my phone.

The Data Network mode is always deactivated now.

Although, when I go to Settings > Wireless and network settings > Mobile network settings, the Use packet data option is checked.

Unchecking this option and checking again doesn't work.

Installing the internet settings again from the service provider also didn't help.

Restarting the phone didn't help.

Restoring factory settings didn't help.

Any idea what's going wrong?

share|improve this question

3 Answers 3

Do not know if you got it sorted but I had the same problem and did this:

  • Tap Settings > Wireless and Networks > Mobile networks > Access Point Names
  • Then tap on one of the relevant APN's pertaining to your provider, such as, for example O2 Mobile Web (Pre-pay or contract)
  • Set the APN Type to 'internet,mms'
  • Tap on Menu, tap on 'Save'.

Back out of the Access Point Names screen, back out to Mobile networks, then:

  • Tap on Packet data (In some ROMs this could be labeled as Data Enabled), and also, Data roaming to turn them off.
  • Turn those two options back on

And voila its working again!

share|improve this answer
    
Are you sure, that APN Type is set to 'internet,mms', what about 'default,supl,mms'? –  t0mm13b Jan 14 '13 at 23:50
    
"Access point names" is greyed out if you aren't on GSM/UMTS... –  Michael Jun 28 at 23:45

Try to put another sim in the handset and see, you will get it.

share|improve this answer

Edit the APN entry (see mel's answer) and delete the SUPL and MMS fields. Select default for the type and then your data will work.

share|improve this answer
2  
Please clarify what you're trying to say here. This is...impossible to understand. –  eldarerathis Apr 26 '13 at 18:45
    
I fixed it, but -1 because I'm pretty sure this won't work -- you don't know what carrier the OP has or if these entries even exist. –  Matthew Read Apr 26 '13 at 23:07

protected by Community Apr 26 '13 at 18:45

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.