Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

As the title says, if I fire up a file browser I can access all the files on the sd-card without a problem. I can even view the pictures with the gallery and the music app plays my music files alright, if I select the file from the browser and then use the corresponding program to deal with it.

If I just use the gallery or the music app or songbird or any other media player, they all report an empty media library. Media on the phone's internal memory can be scanned by these apps and included to their library without a problem.

Here is a screenshot of the settings>storage screen. As you can see it does not even try to index the contents of the sd-card, which are ~6gb of music and a few photos:

After lots of searching around on the web, I found that most people that had this problem, managed to solve it by deleting some stray .nomedia files that were in their sd-cards.

So, I searched my sd card for those files (I know they are hidden), both through the phone's file-browser and by connecting it to my computer, and I failed to find anything. For good measure I backed all my data up, formatted the card, restored the data, cleared the media storage data and restarted my phone, all to no avail. I know that the sd-rescan apps are irrelevant here but I tried one of them anyways. It didn't help...

I should note that I have not tampered with the phone in any way (not rooted, no unlocked bootloader or anything else of that kind).

If someone has any idea about what the problem might be, I'd love to hear from them. Thank you in advance.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I tried formatting the card again, this time on my computer, using gparted and it worked. I cleared the data of the media storage app and restarted the phone and now all media is visible to all apps again!

share|improve this answer
    
Did you format it into FAT32? Or other filesystem? Seems like I'm having a problem similar to yours, except that the mp3 files fail to play even if I navigate to them in a file manager. –  Cyril Jul 21 '13 at 12:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.