Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Since about a week, my S3 doesn't connect anymore via usb to any computer. I don't think it's driver related as it was working before and I didn't change anything on the computers. It now runs Jelly Bean but it didn't happen right after the update (only after a week or so it stopped working).

The S3 doesn't even show the notification with the usb icon nor the possibility to switch between PTP & MTP...

  • I tested with 3 different usb cables, on vista, win 7 and mac os x.
  • Tried to activate / deactivate usb debugging, restart the phone and event done a hard reset, it's still not working.
  • Phone is not rooted

Maybe it's hardware, but the phone didn't fell or anything like that...

Do you have an idea ?

share|improve this question
1  
That seems like an issue for Samsung tech support, as I'm guessing it's hardware. You've already done what I think is sufficient testing to make a software cause unlikely. –  Scott Severance Nov 13 '12 at 6:03
    
I only have this problem on my Mac, it's fine with my other computer running Windows 7 (after installing some drivers - done automatically by Windows). Please update your question if it only applies to Mac –  fuzzybee Sep 11 '13 at 13:45
    
No, it applies to Windows to (as said in my questions, first bullet point) –  ygosteli Sep 18 '13 at 13:59
add comment

17 Answers

Have you checked permissions on your machine? I have had problems accessing my device over usb because of permissions when I connected a device over usb to a linux box.

share|improve this answer
    
Testing on 3 different platforms probably rules this out, but good idea else. –  ce4 Nov 12 '12 at 18:58
    
I'll check again, but as I already tested on two platforms... And the usb icon is not showing in the notification bar. –  ygosteli Nov 12 '12 at 19:59
add comment

Here's what worked for me. I don't know what caused it, but I suspected an Exchange server policy triggered it. I deleted those accounts just in case. Then I rebooted into recovery mode (volume up + home held down at boot). From the recovery menu, I wiped the cache partition. When it came back up, it saw the USB connection just fine again.

share|improve this answer
    
Hello, Thank you for your solution. I've just tried now, unfortunately for me it didn't work. I think that the only way will be to send it to the samsung tech support... –  ygosteli Dec 3 '12 at 14:37
    
This worked for me, thanks! –  jasonhudgins Mar 6 '13 at 17:31
add comment

I've had the same problem with my S3 ever since the update to JB 4.1. My PC would not recognize my s3 and the phone would not go into the usb debug mode only charging indicator when I plug the usb into the phone.
I've solved mine by erasing all cache for apps. Not sure which app it was but right after I cleared all my cache I plug it into the pc and it started working again. Kies works and usb debugging works.

share|improve this answer
add comment

If you pull down the context menu from the top, and select the notification that it's plugged in with the USB device, you should be presented with different options for how you want the phone to treat your USB connection.

Select the Media device (MTP) option and you should now be able to browse the files on your phone just like you would any other usb data device.

share|improve this answer
    
If you read the question it states "The S3 doesn't even show the notification with the usb icon nor the possibility to switch between PTP & MTP..." –  Peanut Jan 5 '13 at 4:35
add comment

If you haven't figured it out by now. The easiest way to fix this is to power your phone down, remove the battery, wait about 30-60 seconds, then put the battery back into the phone. I have had a similar issue and this has fixed it just about every time.

share|improve this answer
add comment

I had the same issue and removing my battery and power cycling the phone allowed the computer to recognize it again.

share|improve this answer
    
As said in another answer : Unfortunately, in my case it didn't solved the issue. But thanks anyway –  ygosteli Jan 19 '13 at 8:39
add comment

A few days after I got the Android 4.1.1 OTA update and rooted it my Galaxy S3 failed to recognize the USB connection.

Removing and then reinstalling the battery allowed my Galaxuy S3 to recognize the USB connection. The Android File Transfer still didn't work until I uninstalled Kies. Now it is working.

I appreciate the posts.

share|improve this answer
    
Unfortunately, in my case it didn't solved the issue. Thanks for the answer –  ygosteli Jan 19 '13 at 8:39
add comment

What seems to work for me is ticking the USB Debugging box in the Developer Options.

I've been trying all sorts of tricks (including some of the above, and more), but nothing helped.

This one does!

Hope this will solve your problem...

share|improve this answer
add comment

From within JB, unplug cable from handset and follow this:

  • Go into Settings > About Phone
  • Scroll down to the bottom
  • Now tap on the Build number 7 times, to activate the Developers Options.

Now the Developer's options is activated (it is deliberately hidden from Settings), back out of that screen, Developers Options should be present, then tap that, look for Debugging, tap on USB Debugging to put a check-mark on that.

Then try plugging in the USB cable to handset... :)

Addendum:

Even if the USB Debugging is selected, un-select it and re-select it. This worked for me.

share|improve this answer
    
Oops, edit should have been allowed instead of rejected. Sorry. –  geffchang Sep 18 '13 at 4:47
add comment

You can transfer music to your device using Windows Media Player on Windows 7 and Windows Vista.

  1. Connect your device to your PC using the supplied USB cable.
  2. On your Galaxy S3, Go to Settings > Developer Options > USB debugging.
  3. Open Windows Media Player and click the Sync tab on the right. Your device should be shown in the sync screen.
  4. Drag the music tracks you want to sync to your device to the sync list on the right. When you have added all of the tracks, click the Start sync option at the top of the screen.

When the synchronization is complete, you can disconnect the cable from either your computer or your device.

Source.

share|improve this answer
add comment

This won't help the OP, but may help others. I had the same problem, no help with battery removal/power cycling or developer mode USB debugging, etc. Finally realized I was using a third-party USB cable (freebie from costco). When I used the Samsung cable from the box, it started working again. Costco cable still doesn't work.

share|improve this answer
add comment

I had a cable which worked well (charge and data transfer) until the upgrade to Jelly Bean 4.1.2. Since the upgrade it won't work and I have to change the cable to labelled DATA TRANSFER ONLY, so I suggest trying a different cable.

share|improve this answer
    
Aren't USB cables all the same? –  wonea Feb 12 '13 at 17:35
    
Not for devices, some will only charge your device and some will allow you to transfer files,... The best is to keep your original cable when you buy a smartphone. –  ygosteli Feb 19 '13 at 15:31
add comment

I just had the same problem tonight. All of a sudden my pc wouldn't recognize my S3 when I connected via the USB. I tried the USB debugging first and restarting...didn't work. I popped the battery out and restarted, and the USB icon showed up. Hope that helps.

Thanks for all the helpful troubleshooting ;)

share|improve this answer
add comment

Oh, and something else...the "developer options" is not hidden in settings. I found it plain as day listed in the settings menu when I clicked on "more options."

share|improve this answer
add comment

I had this problem after updating as well. I can only presume it was from updating; I had no issues earlier.

My problem was the USB ports on my keyboard and the front panel of my PC would not recognize my S3. So, I plugged it into the back, and it reinstalled the drivers.

It works fine now; not sure how or why but who am I to argue.

share|improve this answer
add comment

I had the same problem with the phone not being recognised by PC. I tried EVERYTHING (uninstalling, USB cable, debugging, Kies etc, etc).

It finally worked after turning off phone and taking out battery! Couldn't believe it (but happy now).

share|improve this answer
add comment

I tried a different USB cable and it all came together and started working.

share|improve this answer
    
Are you the OP using a different username? If not, I doubt this answers the question. –  Stephen Schrauger Mar 4 '13 at 2:38
add comment

protected by eldarerathis Mar 4 '13 at 2:21

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.