Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sometime after latest official update to Android 4.0 phone began to switch Wi-Fi on by itself when being in sleep mode (or maybe at other times).

Reproduction: turn off the Wi-Fi, leave it in a Wi-Fi enabled area (there are open networks, but no which I would like to use), and next time I look at phone it shows this notification "There are open networks" and has the Wi-Fi enabled.

The reason I'd like to disable this behavior is phone likes to connect to some saved public Wi-Fi's when I'm on the move and browsing via 3G, thus disrupting the loading of pages. So I usually turn Wi-Fi on and off manually.

share|improve this question
add comment

1 Answer 1

I don't have a Incredible S but the steps should be similar:

Go to Settings->Wifi->Overflow Menu Button->Advanced->Keep Wifi on during sleep->Never.
share|improve this answer
    
It's strange. I'd like it would be off in sleep if it was off and on in sleep if it was on. How do I do that? –  constantius Nov 15 '12 at 19:05
    
@Constantius You probably want "Never" then. I've updated the answer to reflect. –  Wesley Wiser Nov 15 '12 at 20:52
    
Unfortunately, it makes Wi-Fi switch off in sleep independently of it's state before sleeping. –  constantius Nov 18 '12 at 16:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.