Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

This strikes me as a bug since the behaviour is incredibly consistent, but perhaps someone here can help me.

I want to use the google developed calendar app as my main calendar app. My phone (a Galaxy S2) came with a samsung developed calendar app (both very conveniently named "Calendar"). At this point, I simply want to disable the samsung calendar app from displaying any sort of notifications (since the google app also displays notifications and I want to use that app).

I have been able to do this by going to settings->Notifications in the samsung app and toggling to "Off".

However, as soon as I restart the device, the notifications are back on their original settings. Anyone else experience this? Anyone know how to make the settings stick?

EDIT: I notice the notification settings of the google developed app (sound, default reminder time, popup) are also not sticking after reboot. Is my device broken? It seems to only be for calendar. Gmail and other apps hold their settings fine.

EDIT 2: Ok, so disabling the samsung app allows my google app calendar settings to stick after reboot. So looks like that is what I will be doing. Anyone know how I can change the vcs file association to this app now?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I don't know how to make the setting stick, but if you are using ICS you can easily disable the Samsung calendar app - so it will act as if it is uninstalled.

You can disable it by clicking the Disable button on the App settings page - just above the disable notifications checkbox.

Once this is done, reboot your device and it will act as if that app is no longer installed!

share|improve this answer
    
Ya, I've done that, and it works, but then for some reason, I cannot set the google developed app to work with appointment files (vcs) which the samsung app handles. It's nit-picky, but if apps just did what they claimed to do, none of this would be an issue :( –  gnomed Nov 13 '12 at 17:54

I've same issue on my S2.

The problem is a conflict between Google Calendar & Samsung stock calendar.

The second one overwrite settings of Google Calendar.

Only solution is disable it and use Google Calendar.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.