Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am recently having an issue where tethering my PC (Arch Linux) to my Galaxy S2 has a very strange result.

While tethered, web surfing on my PC is painfully slow - not because of slow download speeds, but because the latency between fetching the page and the associated images/scripts can be minutes. I have verified this using Chromium's developer toolbox. This has the effect that badly designed websites don't show up for ages due to the browser waiting to download scripts (or time out) before rendering the full page.

Downloading large files, I can average >100KiB/s, so that is not the issue.

If I connect through WiFi tethering, then both the PC and my Asus Transformer tablet have the same issue, so it would appear to be an issue with the phone. Also, browsing on the phone is as I would expect, quite reasonable given that I don't have full signal, but not unusable as the tethered devices are.

I have also tried running a proxy on the phone to see if it was Three slowing me down (some of them apparently use the TTL count to see if you're tethering), but no luck.

This only started recently, and I didn't change anything on my phone at the time, though I have since gone from CM9 to CM10 to see if that would help. I may have changed something on the PC, though it was working fine on the WiFi broadband until that died (another story, hence why I'm tethering)

Hopefully someone can help me, I have a reasonable level of skill on Linux, so can help in possibly obscure ways if required. Just not sure where to start looking - the fact that both tethered devices have a similar problem points to it being the phone, but not sure how to diagnose what might be causing it.

Hopefully that's enough info, but if you need more just ask :)

share|improve this question
BTW, I wrote this on my phone, so hopefully it makes sense due to reviewing it is difficult on a 4.5" screen :) – MattJenko Nov 16 '12 at 18:17
buffer bloat? you could cross check using USB and bluetooth tethering your mobile data plan. Additionally, do you get the same errors when tethering a wifi connection instead of 3G (via USB or Bluetooth)? – ce4 Nov 16 '12 at 22:11
Yeah, I thought that too, but have rebooted the phone and cleared caches, and it still happens upon first boot so I don't think so. I don't have a WiFi connection to tether so I can't test that at the moment, though if it gets sorted soon enough I will. Also, I've noticed Google searches are still quite quick, though this could be due to there apparently not being much supporting content to a page, and most of that seems to be coming from my cache. – MattJenko Nov 17 '12 at 9:47
Any progress so far? I hope it's not Three here not playing nicely. Oh: Does it only happen with http or also https? PS: have you tried using 2G only already, just to sort out if the problem is only on 3/4G? – ce4 Nov 18 '12 at 21:33
Sorry, have been away for a few days in Strasbourg - I think I've figured it out, and it's Three killing me for tethering. Apparently they've been doing some upgrades to their network to crack down on this a bit, and it seems I've been bitten. I get massive latency at a Three server when tracing from my PC, but not so much from the phone. Bugger - just gotta wait a couple more weeks for someone to flip a switch for our broadband connection :( – MattJenko Nov 25 '12 at 23:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.