Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm using a Rikomagic 802III running Android 4.1.1, connected to my TV. Until today, I was able to connect to Google Play, and my widgets were showing data. Now, when I open Google Play, I get an error, after it indicates "Connecting", "Cannot Connect".

I've got some other widgets, like Google Analytics that also say "offline". However, I am able to browse online through Chrome, and my account is linked. When opening my analytics app, I briefly saw some exception error but haven't been able to reproduce.

When I go to Google.com in the default browser, I see an error indicating" This certificate isn't from a trusted authority" but it all appears to have Google info:

  • Common name: *.google.com

I seem to recall some kind of Google certificate related issue on my desktop where I would see a similar error, and was told it had something to do with the system time.

Has anyone experienced anything like this and/or know how to fix it?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Turns out that the solution for this problem is the one I alluded to above.

The system date/time preceded the certificate's issue date, and I suspect that was causing the problem.

Setting the date to the correct date (or sometime between the certificate's issue and expiration date) seems to have solved the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.