Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy S3 and I love the new Gmail app. Works awesome. My only problem is that it doesn't sync emails (I don't receive any new notifications when new emails arrive, I have to manually click refresh in the app which is annoying) when I'm on Mobile Data. When I'm on Wifi I receive notifications almost instantly. I've searched on Google Help but couldn't find anything.

I guess I could use the Email app but I don't like that as much as the Gmail app.

What could be the problem?

share|improve this question
1  
Please, don't sign your posts, your signature is already on the bottom of the post –  Markissimo Nov 22 '12 at 18:18
    
Also, are you running any custom ROM or it's stock? –  Markissimo Nov 22 '12 at 18:34
    
It's possible that your phone is set to restrict data while on Mobile Data -- Android 4.0 and newer have this feature. Poke around in the settings and see if that's the case. –  offby1 Nov 23 '12 at 0:30
    
I've upgraded to Jelly bean and I have the same problem. Found that setting in Settings > Mobile Data > Gmail > "Restrict background data" but it's disabled so that's not it... –  Cris Nov 27 '12 at 6:06
    
I did a factory reset and that didn't solve the problem. –  Cris Nov 27 '12 at 7:05

9 Answers 9

This thread solved my problem. I could not read android gmail reply. It showed as received as i could see the first few words but could not read reply. It wouldn't scroll down. I went to the settings and saw the Google icon. It said sync was off. When pressed it came up with lots of manual syncs. It had not synced since I got it. Odd that it was receiving gmail but not the reply. (I rarely use gmail on mobile). Hope this helps someone.

share|improve this answer

Just found this thread and it helped me solve the same issue (gmail not syncing on mobile data) on my Galaxy S3. Under settings/data usage/gmail I found that 'restrict background data' was ON. Just for gmail, not globally. Not sure when or how that got checked, but it may have been that way out of the box since my gmail has never synced on mobile data, even with a factory wipe.

Anyways, hope that helps someone else out there.

share|improve this answer

My Phone Galaxy S4:

On mobile network only my Gmail app was not pushing automatically, gmaps was slow, youtube was not working or really slow and Calendar wasn't syncing.

After looking on the internet I was not able to find the solution. I have tried everything that was simple like clear cache, reboot, sync OFF/ON ...

But finally with this site I come up with the APN reset solution. I did it and also I have found that google services had the check mark ON for restrict background data. Setting/data usage/google services

I have never touched this option before so I don't know why it was checked. After these two steps my phone works perfectly now.

share|improve this answer

If none of the other things work, go to Apps > Google services framework. Click Clear cache and data button. Then, reboot.

share|improve this answer

It might be caused by a proxy server configured in the APN. See this question: Google apps losing connection to the servers when on mobile data.

share|improve this answer
up vote 1 down vote accepted

Found out the problem. Orange Wap was selected instead of Orange Internet in Settings > Access Point Names.

share|improve this answer

Yes, this sync was my problem too...just tried below settings and worked:

  1. Go to Settings
  2. then to Data usage
  3. click Menu button
  4. check Auto Sync

Now go to your Account section where you should see all account syncs are enabled :)

share|improve this answer

Ensure that on the device Settings | Data usage | Mobile | Mobile data is set to ON and that if Set mobile data limit is checked that you haven't reached that limit.

share|improve this answer
    
It's on and there's no limit. I've updated to Jellybean and I have the same problem. –  Cris Nov 27 '12 at 6:05

Are you sure that the Sync option is enabled for gmail?

Go to Settings->Accounts->Google->Your account -> Gmail this last must be checked.

Also check if the Sync option is active at all.

share|improve this answer
    
Thanks for the reply. Yes, my Gmail & everything from google on Accounts and sync is checked. It works fine when on Wifi, just not on mobile data. –  Cris Nov 22 '12 at 18:28
    
Try to clean the app data. Go to Manage Apps->Search for Gmail app->Clear Data and Clear Cache –  Markissimo Nov 22 '12 at 18:32
    
done and still doesn't work –  Cris Nov 22 '12 at 19:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.