Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Most songs in my collection display correctly. However some will display the name of the song as "01 Song name" instead of "Song name". Note that the file name is "01 Song name.mp3". They also appear out of order in the album so doesn't seem to be taking the track number into account.

When I check the id tags all the information is correct.

This occurs in all media players that I have tried.

Does anyone have any ideas why this occurs and how to correct it?

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

Are you sure your tags are correct, it sounds like they're not?

Try looking at the files with something like MP3Tag or MediaMonkey they should show exactly which tags are in there and let you clear out any corrupted tags.

share|improve this answer
    
I think you are right. But it is a little strange. On my PC the Tags look correct. Some players show that the tags are correct but PlayerPro shows empty tags. If I load them in iTag the correct values come up and then I save them. Then they are correct all the music players. –  sickgemini Dec 6 '10 at 23:59
    
It's not that strange once you start to see the mishmash of different tagging pseudo standards. Between ID3v1, ID3v1.1, ID3v2.3, ID3v2.4, and APEv2 it's bad enough. Then you have the differences between how different players use those tagging standards to store information. Add in the various tag parsing, writing, and codepage bugs and hacks in different players over the years, and it's amazing that any info can be passed between programs at all. –  afrazier Feb 8 '11 at 16:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.