Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Having become fed up with a custom ROM i was using, I reverted back to a previous ROM via a nandroid backup (through CWM Touch). It would appear that the backup preserved all my installed apps and data (Was under the impression they didn't, so this surprised me somewhat), but since then the 'My Apps' listing on the google play website has been out of sync with what is actually on my phone. I also seem unable to request (un)installation through the web interface.

Help would be muchly appreciated.

share|improve this question
    
Did you check that your Google Account is still linked in Settings > Accounts and Sync? –  Lie Ryan Nov 27 '12 at 14:03
    
Yep, i I tried removing the account, then adding it back through the play store, to no avail. –  AClockWorkLemon Nov 27 '12 at 18:41

1 Answer 1

up vote 0 down vote accepted

It may be the link to the Play store was lost. I think if you install an app from, say, the amazon app store, Google Play will not be able to update or uninstall it, as the link is gone. Similarly, restoring an app from a previous rom backup may not create that link.

Titanium Backup can recreate the links (the free version can can't do this). Or you could uninstall the app and try installing it fresh from Google Play.

share|improve this answer
    
Where would I find the option? All the references to relinking apps on the android market/google play that i've managed to find required the donate/pro edition. (I'm probably looking in the wrong place) –  AClockWorkLemon Nov 27 '12 at 19:14
    
Not to worry. Ended up buying a TiBu PRO key anyway. Market Doctor fixe it up perfectly, thanks. –  AClockWorkLemon Nov 27 '12 at 19:25
    
Sorry, it looks like you're right. The re-linking requires the Pro version. I was looking in the summary of the app and it implies it is in the free version as well. Glad you got your problem fixed! –  Stephen Schrauger Nov 27 '12 at 19:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.