Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Motorola Droid and have just installed the latest update.

The Wi-Fi network at my workplace is temperamental, so I prefer to simply turn off the Wi-Fi and use 4G.

The issue is, when I turn it off (in Settings ~> Wi-Fi ~> move the slide bar to "off") it shows as off, however the next time I turn the screen on, the Wi-Fi is back on.

How can I stop this?

share|improve this question
    
My guess is that your carrier has installed some sort of "connection optimizer" onto your device with the most recent update. Which actually just means that it will use wifi when it is available because that will result in less overall traffic on their 3g/4g network. On sprint device you can go to Settings->wireless & networks->more...->-mobile networks->connection optimizer to enable / disable this. try poking around your wireless settings to see if you have something like this. –  FoamyGuy Nov 28 '12 at 21:01
add comment

2 Answers

This is strange behavior, and one I have not actually seen before.

Do you by any chance have an app installed that could be turning the Wi-Fi on? Also, how long do you wait between sliding the slider and turning the screen off - it may not have had time to update.

I have only ever since this issue once, and I believe that it was a software issue.

If you cannot fix it, I would recommend 'forgetting' your works Wi-Fi network, so that Android does not automatically connect to it. You can do this by long pressing on the Wi-Fi network in the Wi-Fi settings menu.

share|improve this answer
add comment

The comment on the question:

My guess is that your carrier has installed some sort of "connection optimizer" onto your device with the most recent update. Which actually just means that it will use wifi when it is available because that will result in less overall traffic on their 3g/4g network. On sprint device you can go to Settings->wireless & networks->more...->-mobile networks->connection optimizer to enable / disable this. try poking around your wireless settings to see if you have something like this.

This solution worked for me. I have had the same problem as the OP since I upgraded to Android 4.0.4 a couple months ago on the Sprint network. 4G and Wifi would both turn on by themselves at random times, no matter how many times I turned them off.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.