Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Chinese MID9000 tablet, and when I tried to install an app it took forever. I checked why and the device said that internal storage had 00.00 bytes when I hadn't even installed anything yet. Everything else functions perfectly except for app installation and the fact that it always acts like it's the first time opening it when I restart it.

So I tried to factory reset it from the settings menu to see if it would fix the issue, but all I saw was an Android laying on its back with light blue circuits running through it for a second, then it flashed to a red exclamation mark. Now I have a 150 dollar piece of tech that is useless.

I don't want to send it back to Newegg because I want to see if there is any way to get it working first to avoid the hassle. I have tried searching for solutions, but everything I found required a Windows computer and I use Ubuntu. Are there any solutions that don't require using a Windows computer?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.