Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

The new swype-style keyboard on my 4.2.1 updated Galaxy Nexus is great. However, when I attempt to express myself more colorfully, the swiping action does not yield the word I would like to write. The word is already in the device dictionary though, so it does not let me add it to the dictionary to be recognized, as I have done with other words. Does anyone know how to fix this?

share|improve this question
    
Just had a hunt round myself (also on a 4.2.1 Galaxy Nexus) my "Google Voice Typing" settings does not have "Block Offensive Words" selected. I can type offensive words by tapping the keyboard keys without any problem, I just can't "swipe" them, even if its the exact same word I just tapped out with no problem. Can't see any swipe setting to allow all words. –  GAThrawn Dec 3 '12 at 9:35

3 Answers 3

I what I will call a workaround for the present, as it is not a simple solution as allowing offensive words in voice typing, but it has the same final affect:

  1. Under Settings, choose Language & Input
  2. Choose Personal Dictionary
  3. Click the plus (+) button in the top right
  4. Enter the "offensive word" under the Phrase and Shortcut spaces
  5. Click the back button (system or top left)
  6. Enjoy your custom swipable profanity
share|improve this answer
    
You should accept this answer since it's the best and "only" solution I've found that works. –  slybloty Mar 3 '13 at 4:25
    
I swear! Often! And somebody should make a personal dictionary app preloaded with all the color language you could possibly want. I'd pay for that. –  Zooks64 Apr 22 '13 at 0:01
    
impossible to do on a samsung ROM. I hate that f^^^^^ good thinking speaking moral that drive the world what if I'm a doctor and want to speak about vagina ? How should I call that? the shell ? –  Kiwy Dec 27 '13 at 14:50

I have a Nexus 4 from T-Mobile, the Google one, with Android 4.2.2. I've been noticing this same problem, and the fix I found was to go to Settings -> Language and Input -> Then press the settings icon next to the "Google Keyboard (English, U.S.)" option -> then deselect "Block offensive words." Before I figured this out, however, I spent quite a lot of time painstakingly adding each swear word and each of their various iterations and conjugations to my personal dictionary (both under 'phrase' and 'shortcut'), so this may have helped somewhat for my fix. I can now swype swear words, although often times it is not the automatically recognized word, and I have to manually select it from the list of other possibilities that comes up. I suspect that as I type the swear words more often it will begin to use them by default. As for the voice-to-text options, I don't really know how to fix it, because I rarely use it, however I would suggest trying the same thing (i.e. finding it under 'settings' and deselecting 'block offensive words,' or some similar option). Hope this helps!

share|improve this answer

Some keyboards have a kind of "blacklist" for bad/insulting words. Check if you can find that option in Settings → Language & Input, where you should be able to disable it. I know for sure there's such an option for voice input ("Block insults" in Settings → Voice Input & Output → Voice recognizer Settings), but I'm not sure whether that option also applies to keyboard input.

share|improve this answer
4  
Can confirm that the Voice typing "Block Offensive Words" setting doesn't apply to swiping. I can't find any equivalent for swiping. –  GAThrawn Dec 3 '12 at 9:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.