Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I was trying to install a new app from Google Play on my computer, but a message told me that the app wasn't compatible with my device. No more information was given.

Can someone please tell me where I can find the minimum requirements for any given app? I want to check what's missing on my phone. Maybe I can fix the problem, assuming it isn't a hardware problem.

share|improve this question
    
I always assumed because I couldnt install a specific app from the Play Store it was due to Geographic Location rather than because of the specifications of my phone. This article for CNN entitled "Should Android apps list minimum requirements?" might provide further insight. –  Simon Dec 5 '12 at 10:00
    
I forgot to include the link edition.cnn.com/2011/TECH/mobile/06/07/android.app.problems/… –  Simon Dec 5 '12 at 12:13
    
You could look at the Manifest file as suggested in Ifor's answer by using the methods described here: stackoverflow.com/questions/2097813/… or stackoverflow.com/questions/4191762/… –  Peanut Dec 5 '12 at 13:56
add comment

4 Answers 4

up vote 9 down vote accepted

The theory is that you should not need to know. When the developer publishes an app there is a manifest.xml file that describes the required capabilities. These can be both hardware and firmware related. e.g. you need a minimum Android version or you need a specific hardware feature like GPS. Google Play then automatically filters which apps you can see and install based on these requirements. The developer can also impose geographic requirements and potentially carrier requirements as well as disallowing specific devices if they want to.

In your case the obvious thing to do is to first check if the developer has a website with any more information. If that's of no help try emailing them the filtering can be tricky and catches developers out. If the developer is at all responsive they should come back to you. It is in their interest to have the app work on as many devices as possible normally, so if there is no good reason for it to be incompatible with your device they should appreciate the opportunity to work out the issue. If there is a valid issue then your question may help prompt them to make the information available on a website or in the description.

share|improve this answer
add comment

The simple answer: You cannot.

The expanded answer: You cannot, unless the Developer has specified this on their site. You could also email them to ask them.

The developer uses the manifest file of their app to specify certain hardware or software version requirements for their app - Google Play then uses this info so that it doesn't install an app on an incompatible device.

Some examples of what they could put are:

  • Minimum Android version
  • Maximum Android version
  • Hardware requirements
    • GPS required
    • You need to have an accelerometer
    • You need to be able to use portrait/landscape mode

If the app uses the NDK and it is built for Armv7, you will need an Armv7 device.

share|improve this answer
1  
Sorry to correct you: But you can. There are tools available which let you browse the Manifest file. –  Izzy Dec 5 '12 at 15:48
    
@Izzy I was supposed to say you can edit the manifest, but I wrote this in school, and quickly. –  Liam W Dec 5 '12 at 16:03
add comment

As the other answers already state, requirements are stored in the .apk's Manifest. There are several tools available to help you analyze this file, as e.g. is described at StackOverflow's question How to view AndroidManifest .xml from APK file?. Examples given in the answers include:

Then there also are...

...and probably many more.

share|improve this answer
add comment

The simplest answer to your question would be that the developer has excluded your device from the list of supported devices.

This could due to the following reasons:

  • Your phone might be causing some problems with the app. This can lead to the developer excluding your device.
  • The developer has excluded devices of certain form factors.
  • The developer may be targeting only particular handsets.

You might be able to get details of supported devices from the developer's website.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.