Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I just updated to Jelly Bean on my GS3 and am mostly impressed.

I am having trouble with the screen timeout setting, however. When I go into Display>Screen Timeout and select a time, say 30 seconds, I get a message that says "Screen will turned off when screen is locked. Secured lock time is currently set to 5 seconds." My question is where? I cannot find this Secured Lock time setting in Display settings, Lock Screen settings or Security settings, which would seem to be the intuitive places to look for it. Further, even though I get this message, my screen now does not turn off at after 5 seconds, or ever as far as I can tell. After walking away from the phone for 20 minutes, I returned to the screen blazing in all its AMOLED glory.

share|improve this question
2  
If I understand that right, your screen should turn off after 30s idle time. If you switch it back on within less than 5s, you won't have to unlock (lock screen). After that "grace time" is exceeded, Keyguard takes over and enables the "lock". That's how your "configured part" sounds. I have no explanation, however, for the 20min thing -- except that some app might keep the screen awake -- here it might help if you specify what is running when that happens. –  Izzy Dec 5 '12 at 22:38
    
Thanks, Izzy. Your comment about an app running that might be keeping the screen awake prompted me to do a restart, which resolved whatever was going on. Screen turns off after 30 seconds and locks after 35. Appreciate the feedback! –  Paul Dec 5 '12 at 22:51
    
Glad the hint helped! I took the freedom to turn it into a more detailed answer (giving additional hints). –  Izzy Dec 5 '12 at 23:13
add comment

2 Answers

As said in my comment on the question itself: That settings page is the place to configure the default behaviour. In your described case, those settings define the screen to switch off after 30s of idle time (i.e. no touch event), plus activate the Keyguard action (i.e. the lock pattern, PIN, or password) after additional 5 seconds (so if you switch the screen back on within less than 5s after it switched off automatically, you do not have to unlock the device as it would not yet be locked).

Now why does the screen stay on for 20 minutes or more, though configured to switch off after 30s of idle time? The solution is not always that obvious. Apps with the appropriate permissions might override those default settings. A good example is a navigation app: One surely doesn't want to permanently touch the screen to keep it from switching off while navigating. Another example might be an ebook reader prolonging the timeout.

While a reboot might solve that issue once it happens (in case a quick-fix is needed), in the long run it will prove better to check running apps for candidates overriding the mentioned default settings. While the navigation app might be obvious (and most likely desired), other apps might let you configure this behaviour.

In case you cannot easily figure out which app is causing it, a look at the system logs might prove useful. aLogcat is one example of apps helping you to capture log contents (there are many others as well). It might produce a large amount of lines, but searching the content for strings like "screen", "timeout", and the like has good chances to narrow it down.

share|improve this answer
add comment

Your problem is not in display but in Lock screen. I had the same problem and fixed it: Go to settings, lock screen, then secured lock time, and set it for ten minutes

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.