Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was sure in the version prior to 18.0 you could fiddle around and long press on the URL in the address bar and get a menu to copy the current URL.

I just updated Chrome, now if I long press it I just get the magnifying glass which is incredibly frustrating. How can I copy the current URL to the clipboard in the Chrome browser?

Chrome 18.0.1025469 Android 4.0.4 Sony Xperia P

share|improve this question
up vote 8 down vote accepted

Turns out I was doing it wrong (well at least on my my ROM).

You need to perform two double-taps.

  1. Double tap the URL. The first tap will select all of the URL and the second will deselect it and give you the text cursor and that little text selection tab helper thing.
  2. Double tap the URL again to bring up the menu.

Or you can just keep quickly tapping until the copy menu appears. I find this whole process to be a bit unusual.

Other people are saying that they can long press to copy, so not sure if the above is specific to Sony ROMs.

share|improve this answer
Long tap works in my Galaxy Nexus, the steps you describe work here too. – Francisco Alvarado Dec 7 '12 at 6:53

It just might be about your ROM.

I have the same version of Chrome, on Android 4.1.2. When I select the URL and long-press, I am getting a row of buttons, which of course includes a 'copy' button.

share|improve this answer
You could be right. This week I updated both the ROM and Chrome. – row1 Dec 6 '12 at 6:50
@row1 I'm also using the same Chrome version, but on Android 4.0.3, and can confirm that long pressing the URL does bring up the cut/copy/paste button bar. – fernio Dec 6 '12 at 11:09

Try this free app: To Clipboard

Install it and it will be added as a new share option, so you can send there the URL from Chrome.

share|improve this answer
This works very well. Will wait and see if I can get any fixes/explanations for Chrome before accepting. – row1 Dec 6 '12 at 6:48
I don't think this is a Chrome issue, but a manufacturer ROM related "feature", because I had all versions of Android since 4.0 until 4.2.1 in my Galaxy Nexus and I never had any problem to copy URLs in Chrome. – Francisco Alvarado Dec 6 '12 at 6:51
It was working a few weeks ago when I last tried it. Since then have updated the ROM and Chrome. So could be the ROM. – row1 Dec 6 '12 at 6:53

You could workaround this problem by sending the page to Gmail App, and there you can copy the URL from the draft message body. Then you can delete the draft from Gmail.

Action bar --> Share... Select Gmail Copy URL from message body

share|improve this answer
Have previously tried this. It is quite messy as you need to then exit edit mode (can't seem to select text), then load the draft (non-edit mode), then long press the URL to copy. Does work though. A share to clipboard app would be better. – row1 Dec 6 '12 at 5:58
Android 4.2 has the new sharing option "Copy to clipboard". – Francisco Alvarado Dec 6 '12 at 6:00
Thanks for the screens. I can't seem to copy it from your 3rd screen. I need to exit edit mode. Not sure if Sony will ever give me the 4.2 update ... well at least not any time soon :( – row1 Dec 6 '12 at 6:45
I don't understand what you mean with "exit edit mode". Please could you explain better this? Maybe a screenshot could be helpful too. – Francisco Alvarado Dec 6 '12 at 6:54
Go back to your labels and selects drafts. Select a draft email. You are now previewing the draft and need to press the 'pencil' icon to edit it. I cannot select text from this preview mode, but if I long press on the URL I get an option to copy it. – row1 Dec 6 '12 at 6:56

Use share from more(3 vertical dots) besides address bar. You will get copy to clipboard from various options of sharing. (Android 4.2.2 on Sony xperia z)

share|improve this answer
If you don't have this, you can get it by installing copy to clipboard – ce4 Aug 1 '13 at 4:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.