Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I'm browsing the net using the Internet app (the default browser), youtube links open up in the browser and not in the youtube app. I don't get to choose any option like before. In Applications Manager > Internet there are no defaults set. I tried clearing cache & data for Internet & Youtube app but I still have this problem. Same thing with Facebook youtube links, they open in the browser, no option to have it opened in's driving me crazy

I'm using a Samsung Galaxy S3 with Jelly Bean.

Turns out this problem is also on the HTC EVO (, something to do with an Apple lawsuit. If I remember correctly, I didn't have this problem when I had Ice Cream Sandwich on.

Also, if I long press a YT link in the browser, no option shows up to open it in the app? What gives?

share|improve this question
What do you mean by "browsing the net using the Internet app"? What is the "internet app" you are using. Do you mean default browser? – Pandoo Dec 6 '12 at 20:04
You could try uninstalling the browser then reinstalling it? See what happens to the links in the mean time on a different browser? – Peanut Dec 6 '12 at 20:45
Yes, the default browser. – Cris Dec 6 '12 at 22:51
I can't uninstall the browser, the uninstall button is grayed out. – Cris Dec 15 '12 at 8:49
Have you tried reinstalling the youtube app? – Power-Inside Dec 15 '12 at 9:01

Try resetting app preferences. Go to Settings->Apps, choose from menu Reset app preferences and confirm Reset apps. This will reset all app preferences.

To reset preferences for specific app (e.g. Browser), choose it in Settings->Apps and press Clear defaults button in Launch by default section.

Next time you try to open YouTube video you should be asked which app to use.

These instruction were verified on pure Jelly Bean (on Galaxy Nexus).

share|improve this answer

I had the same problem, here's one way to fix it: set user agent string as desktop.

To do so, type about:debug in address bar to get debug settings, then go to Settings > Debug > UA String. Set it to Desktop, restart browser and load any YT URL - it should show you the option to open YouTube app.

Tested personally on Nexus S running Android 4.2.

share|improve this answer
Thanks Sumesh, but that doesn't work either and I did everything like you said even rebooted the phone. Oh well... – Cris Dec 17 '12 at 9:22

FacebookLinks fix the problem of Facebook, it allow you to open youtube post from Facebook directly using Youtube app!

share|improve this answer
Welcome to StackExchange and thank you for your contribution! If you want some badges, fill out all of the fields in your profile and read the "About" link near the search box. Enjoy StackExchange! – Devyn Collier Johnson Jul 21 '13 at 1:08

Goto Apps in Settings and clear the youtube app preferences. It will reset your data and you will be prompted to open videos.

share|improve this answer

This really worked for me! Just follow these steps:

  1. Go to Settings
  2. Go to Apps
  3. click on the Google Chrome app
  4. Go down and click "clear defaults"

Your all done and the next time you click to watch a video it should give you the option to chose Youtube app.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.