Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I use my Google voice number as my main number at my desk. The calls ring in Gmail and I answer them there as well as make calls there from my address book. With fellow Gmail/GApps users, I also receive calls via the "voice chat" feature in GMail. However, ever since I got my Galaxy S3, if I am not active in the GMail window, voice chats ring only on my phone and Google Voice calls do not ring at all unless I go back and do something in the GMail window prior to the call. The calls just ring and ring and eventually go to voicemail (in the case of Google Voice calls). Google voice is configured to send calls only to my PC - I do not want to receive calls on my Android while I am at my desk.

share|improve this question
1  
Hmm. This sounds similar to how Google Talk behaves. If you have multiple clients, messages only get sent to the most-recently-used client (with some exceptions). I am not sure why Voice would be acting similarly. –  Matthew Read Dec 6 '12 at 21:57
2  
@MatthewRead: GV uses the Gtalk client when used through Gmail. I bet that's it. –  Al E. Dec 6 '12 at 22:22
    
@AlEverett: Yes, I believe that is the issue. The question is, how can I get around it? It even happens if I am not actually using the GTalk client on my Android, as long as I am using the phone (e.g. Angry Birds). –  Aaron J Spetner Dec 6 '12 at 22:46
1  
I'm willing to bet it's just a settings problem. I've always had GV ring all my lines and it's never mattered when I last touched Gmail (it always also rings). Which setting, though, I'm not sure. Perhaps some experimentation? –  Mr. Buster Dec 6 '12 at 23:16
    
@Mr.Buster: Not sure - there aren't THAT many settings. My GV number is only set to ring in GMail - nowhere else. This even occurs while I'm on a call. If I'm doing something on my Android while I'm talking and another call comes in, I won't get call-waiting. –  Aaron J Spetner Dec 6 '12 at 23:40
show 2 more comments

1 Answer

This Chrome extension offers an always-running background process for Google Chat. This has worked for Google Voice for me and may give the GV/gmail chat protocol the priority that you seek (If you happen to be using Chrome). Ideally the fix should come from Google making GV a higher priority, but this could be a good work-around for you.

share|improve this answer
    
Well this seems to fix it for now. Annoying, though. I don't see why Google can't fix it themselves though. Thanks. –  Aaron J Spetner Feb 9 '13 at 23:08
1  
I had to stop using this plugin - it completely screwed up my alt-tab order and often an "invisible" call would ring and I would be unable to find where to answer it. –  Aaron J Spetner Feb 28 '13 at 16:40
    
Please fix this Google!! –  lazfish Mar 1 '13 at 10:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.