Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I wasn't satisfied with the selection of sounds the phone was giving me for the alarm, so I installed ES File Explorer and picked out some ringtone sounds from the phone's system/media/audio folder. Ever since, those sounds have been showing up in the Music Player playlist.

How do I stop them from doing so?

I'm using the default music player on a Sony Ericsson Xperia X10 Mini Pro running Android 2.1.

share|improve this question
1  
Just a guess (hence not an answer but a comment): it might be that's some "cached info" somewhere. You could try walking your apps (settings > apps > manage apps) for all fitting things (media player, media scanner, es file explorer...) and delete their caches. Check whether that solves the issue. If not, you could try to delete data for media player/scanner (at least scanner data should be rebuilt on the next scan; the player would lose its configured preferences when deleting data). Please report if that did the job; if so, I'll convert this to an answer. –  Izzy Dec 7 '12 at 11:10
    
The Music Player i'm using is the default phone/system one, so it's not present under installed apps in app manager, neither is the Media Scanner. So i don't know how to delete their caches or data. I deleted the cache for ES File Manager, and using ES Task Manager cleaned the whole cache. I just restarted the phone and the specific system audio files still show up in the playlist. –  Stefan Stlokic Dec 7 '12 at 17:32
    
You probably look in the wrong section. System apps do not appear under "downloaded". I cannot remember how it looked in Eclair (too long ago), but there must be an option to "show all". –  Izzy Dec 7 '12 at 18:10
1  
So apparently i cleared the data from the wrong app, which wasn't the Media Scanner. I found the Media Scanner app, cleared the data and it fixed both the duplicate entries and the original problem. So your advice was spot on. Thank you for being so forthcoming and helpful, both you and @SurajBajaj –  Stefan Stlokic Dec 7 '12 at 21:03
1  
@SurajBajaj Done, thanks for the wake-up call :) –  Izzy Dec 8 '12 at 18:28

2 Answers 2

up vote 0 down vote accepted

As my suggestion in above comment seems to be relevant, I hereby convert it to an answer as promised:

It might be that's some "cached info" somewhere. You could try walking your apps (Settings → Apps → Manage Apps) for all fitting things (media player, media scanner, es file explorer...) and delete their caches. Check whether that solves the issue. If not, you could try to delete data for media player/scanner at the same place (at least scanner data should be rebuilt on the next scan; the player would lose its configured preferences when deleting data).

Keep in mind to check all apps (not just the downloaded section: the latter only applies to the apps you've installed yourself, while the former also includes system apps).

When you've cleared cache and data, you library might appear empty at first. This is no bug or problem -- it's just the Media Scanner needs to rebuild its library. This happens on certain events:

  • after a reboot
  • after a re-mount of the sd card (e.g. plugging it into your computer via USB, then disconnect it again)
  • when another app triggers it (take e.g. a look at SDrescan for this).
share|improve this answer

Add a blank file named .nomedia in the folders containing music that you don't want to be seen in the music player. Media scanner ignores files in the folder with .nomedia file. I have never tried this on Eclair, but I guess it should work.

And yes, you may have to restart the device after this is done.

EDIT:

The restart is to trigger the Media Scanner to do its job. You can also trigger it by unmounting and remounting your SD card (which can be done from Storage Settings or by connecting it to your computer), or by using one of the "trigger-happy-apps" like e.g. SDrescan

share|improve this answer
1  
The restart Suraj mentions is to trigger the Media Scanner to do its job. You can also trigger it by unmounting and remounting your SD card (which can be done e.g. by connecting it to your computer), or by using one of the "trigger-happy-apps" like e.g. SDrescan. –  Izzy Dec 7 '12 at 8:26
    
I can't do that. Like i said in my initial post, the files that are showing up are from the phone's internal system folders, they aren't on the media card. The phone won't let me a copy files into it's internal system folders. Even if i could put a .nomedia file into the correct internal folders, i'm not certain how it would effect the functioning of the phone, and if the media files in those folders would still be visible and available to the phone to use as ringtones and such. –  Stefan Stlokic Dec 7 '12 at 8:58
    
I appreciate the help guys, but you haven't addressed the greater problem, which is that the phone won't let me copy files into it's internal system folders. –  Stefan Stlokic Dec 7 '12 at 9:31
1  
@SurajBajaj When you update your answer, feel free to integrate the information from my previous comment. Makes it easier to catch. –  Izzy Dec 7 '12 at 11:05
    
@SurajBajaj Right, i'm not rooted. I'm using the phone's default music player, the phone is an X10 Mini Pro. –  Stefan Stlokic Dec 7 '12 at 11:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.