Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Whenever I need to install a bunch of updates, I find myself sitting next to the phone/tablet and tapping the screen every 20 seconds, else the updates never complete.

There must be a better way! Right?

What I've got:

  • Sony Xperia Arc S, with 4.0 - pretty sure the updates stop when the screen goes out.
  • ASUS Transformer Pad, with 4.1 - will have to re-check whether the updates stop now that you guys mention they are expected to carry on.

How I'm connecting: Wi-Fi.

share|improve this question
2  
You mean the updates stop when the screen goes off? –  Suraj Bajaj Dec 10 '12 at 11:40
1  
What phone have you got, what OS version is running on it, and how are you connecting to the internet at the time (wifi, 3G, etc)? That's not how it should work, the updates should carry on downloading and installing regardless of whether the screen is on or off. –  GAThrawn Dec 10 '12 at 12:01
3  
Just increase the screen out time. In ICS, it's settings>display>sleep. Maximum is 30 mins. Hopefully updating will be done before then –  Sid Dec 10 '12 at 12:41
    
@romkyns How are you connecting to the internet when you're updating, if wifi we have a lot of previous questions about wifi disconnecting when the screen goes off, that could be the problem that you're having? See How do I keep my wi-fi on in sleep mode –  GAThrawn Dec 10 '12 at 17:49
    
The fix that I found satisfactory in the end was to set the sleep timer to 10 minutes, as suggested by @Sid. I'm the type of person who likes to manually turn off my phone anyways, since otherwise random things get activated in the pocket. –  romkyns Jul 31 at 23:27

4 Answers 4

There an app developed to deal with that issue, Smart Timeout Keep Screen On by guidology available from Google Play Store:

Smart Timeout allows you to specify apps that will keep the screen / display on. Once there are no specified apps visible on the screen the normal screen timeout is enabled.
Works great while reading articles in web browsers, email, or any app you specify. You'll no longer need to worry about touching the screen to prevent the screen from sleeping, dimming or timing out.

Printscreen 01 Printscreen 02

Ain't free, costs 0,76€, but "saves" you from the described annoying situation :)

share|improve this answer

Though I don't know about any "official way" (did I miss some option in the playstore app?), I can think of a work-around using Tasker (or a similar automation app). As a long-term Tasker user, I can best describe it for this app, which is the most feature-filled and complete automation solution for Android (but for sure not the cheapest and easiest one). You might be able to adapt that to a different tool.

Tasker combines "conditions" with "tasks" to so-called "profiles" -- so let's create a profile "AppUpdates":

Condition: App (select the playstore or whatever market app you use)
Task: Display (disable timeout)

That should do it: As long as one of the selected apps (you can select multiple entries there) is running in the foreground, the display will be kept alive -- and thus the device from going to sleep. Mission accomplished.

share|improve this answer

If you are connected to wifi, then it may be set to turn off when the screen is turned off.

You can use the video linked below to explain how to do it, in essense:

  1. Go to the System Settings
  2. Select WiFi
  3. Press the menu key
  4. Select advanced
  5. Change Wi-Fi sleep policy to 'Always'

Video

share|improve this answer
1  
You mean to "Always", I think, looking at how it's phrased. Mine was set to "Never". –  romkyns Dec 10 '12 at 18:58
    
Yes, that is what I meant. Thanks :) If it was set to never, that would most likely be the cause if you used WiFi :) –  Liam W Dec 10 '12 at 19:48
    
Hm. That doesn't work for me. I have "always" but it still stops downloading updates :-( –  zerkms Mar 6 '13 at 8:06
    
For the record, this didn't work for me either, not really sure why. –  romkyns Jul 31 at 23:25

I saw this issue on my Moto X. I also had the WiFi sleep policy to always and the download would freeze once the phone went to standby.

I found that if I put the Play Store in the background, it will continue to download and install.

share|improve this answer
    
Wow, so simple. This is counterintuitive and I would have never thought to try it. Thank you! Works on Galaxy Nexus (Verizon) w/ CyanogenMod 11.2 (Android 4.4.4). –  Manganeez Aug 22 at 22:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.