Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason I'm getting 2 notifications for every 1 calendar event I enter.

I'm using Android 4.1.2 (CyanogenMod 10.0.0-grouper) on a Nexus 7.

Can someone please help me troubleshoot this issue?

share|improve this question
What calendar app do you use? With some 3rd party calendar apps, you need to disable notifications for either the board calendar or the 3rd-party-calendar to avoid this, as the letter register their own alarms. Could that be your issue? – Izzy Dec 10 '12 at 17:24
Have you set up Outlook or some other mail client? Or as Izzy mentioned any 3rd party calendar app? – Suraj Bajaj Dec 10 '12 at 17:44
i'm noticing the same issue on a SGS3 (d2vzw.) No 3rd party calendar apps and i'm using gmail and do have an exchange account setup. i'm getting the double notifications from both the events in the outlook and google calendars. – jcwmoore Dec 11 '12 at 13:08
The problem was stupidity on my part. – user11532 Dec 11 '12 at 18:00

CyanogenMod 10 includes an outdated Google Calendar app.

When I installed the updated one from the Play Store, I neglected to remove the system Calendar app.

Once I uninstalled the outdated system Calendar app, I only got 1 notification per event.

share|improve this answer
For those that are rooted, you can install Titanium Backup and then force-ably uninstall the old calendar app. The system app management tool doesn't allow it. I am sure that there are other apps outside of TB that will work as well. – pthurmond Sep 23 '13 at 14:46
I've always used the app called "/system/app mover" to make it a non-system app and then remove it normally.. – user11532 May 24 '14 at 6:46

This might be irrelevant since I don't use CyanogenMod

I faced the same problem with HTC One (running Android Version 4.1.2) Calenders conflicting were the pre-installed one from HTC and the Google Calendar (which I prefer). I installed it from Google play, the solution might work also in your case too, but I'm not sure.

From the apps menu go to the App manager, and swipe sideways to the "All" tab there, scroll down to the calendar app you want to disable, click it and then click the Disable button. This did the trick for me. It's worth trying.

share|improve this answer
Yes, I do think that may be a viable solution for those who are not rooted. – user11532 Jul 8 '13 at 17:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.