Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm trying to use HTC MyTouch 3G Slide for USB tether instead of my old G1, which works perfectly.

On the first try the ADB driver didn't recognize the phone, but worked fine after adding this to android_winusb.inf in both [Google.NTx86] and [Google.NTamd64]:

;T-Mobile MyTouch 3G Slide
%SingleAdbInterface%        = USB_Install, USB\VID_0BB4&PID_0E03
%CompositeAdbInterface%     = USB_Install, USB\VID_0BB4&PID_0E03&MI_01

However, when enabling USB tethering, the PID changes to 0E04, and my guess requires to be associated with Remote NDIS driver.

So I've exported the Remote NDIS using Double Driver, and examined wceisvista.inf file. It says that compatible devices are:

%WindowsCeDevice%    = RNDIS.NT.5.1, USB\Class_E0&SubClass_01&Prot_03

While the actual device is: USB\Class_02&SubClass_02&Prot_FF

I've already messed something up by adding the tether mode hardware Ids to the ADB driver.. so now it recognizes it as ADB driver..

Some more details, on the Slide I have cyanogenmod 6.1.0 installed (Froyo 2.2.1), and the PID changes only when using Wired Tether app (code.google.com/p/android-wired-tether). When switching USB Tether within built-in settings, the PID stays on 0E04. So maybe it is suppose to be associated with ADB driver...

At this point my knowledge of windows drivers expires.. Anyone has any experience with this? Thanks!

share|improve this question
    
I should add that I've decided not to waste more time on this and got EasyTether app, since ADB interface works now. –  Unirgy Dec 11 '10 at 18:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.