Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to move the SwiftKey app from my standard user partition to the system partition (I have root). I am able to use Titanium Backup or Link2SD to turn an app into a system app, but anytime I try that with SwiftKey, it continuously force-closes. With most apps, if they start acting up right after changing them to system apps, you simply reboot and it works. However, rebooting doesn't solve the problem with SwiftKey.

I have also tried clearing cache and dalvik cache, but it seems like this particular app hates being a system app.

According to this forum thread, I need to move a library over to the system lib folder, but I don't see any library needing to be copied.

Reinstalling the app looks like it works, but it doesn't really. Because updates to system apps are not stored in the system partition, 'updating' the Swiftkey app makes the app work again because the main binary that is running is running from userland, not systemland. If I then use Titanium Backup or Link2SD to Integrate the update into the system partition, it starts crashing again.

Has anyone been able to successfully move the SwiftKey app into the system partition?

Edit: I have tried clearing the cache, clearing the data, uninstalling completely and reinstalling (then moving to system), and I even tried the same steps on another phone of the same model (Optimus V).

I have also tried manually copying the .apk file over instead of simply using Titanium Backup's or Link2SD's built-in mover. SwiftKey simply refuses to run properly if installed as a system app, but works just fine as a user app.

share|improve this question

First, go to to Root folder then go to "/data/data/" then copy the "lib" files to "//system/lib" and after that, go to root then "//data/app" and copy the "swiftkey" apps file to //system/app and restart your phone. After rebooting open titanium backup, find swiftkey and wipe data. Done. It wont force close again :)

share|improve this answer

If you have root, then its a simple matter of remounting the system partition as read-write and try copying the swiftkey's apk into /system/app, then remount the system partition again, it will then appear as a system application.

Then on first run, it will re-create the libs etc in the respective /data partition.

share|improve this answer
I have been able to move other apps just fine. I have system mounted as read/write. I'm having trouble specifically with SwiftKey. – Stephen Schrauger Dec 11 '12 at 20:28
@dymutaos Did you try Titanium Backup's functionality to "integrate" a system app? Not sure if that helps, it's just an idea. – Izzy Dec 11 '12 at 20:45
I couldn't remember the terminology until you mentioned it. Yes, I tried that. I'll update my question to use the proper term. – Stephen Schrauger Dec 11 '12 at 20:47

As you have root, all you have to do is find the SwiftKey apk file using a file manager such as root explorer, and then cut it to the /system/app directory.

Once this is done, go into Settings->Apps->All->Swiftkey after rebooting, and select the clear data option.

It should not work without force closing.

share|improve this answer
I tried that, and it didn't help. The data was cleared, and while still on that screen, SwiftKey crashed twice (I waited to see if it simply would crash the once after clearing the data). – Stephen Schrauger Dec 11 '12 at 20:38
Then this is very strange (never seen this before). Have you tried uninstalling swiftkey, then copying it to the /system/app partiton? – Liam W Dec 11 '12 at 20:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.