Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Both of my Galaxy S3s have a problem with their proximity sensors. I make a call, put the phone to my ear, but then if I want to hang up the screen is dead and won't wake up. I cannot disconnect the call until their answering machine hangs up. If they don't have an answering machine, the call just rings and rings until I remove my battery. This is my second S3. Is there a fix for this?

share|improve this question
1  
Do you use some kind of screen protector or smartphone case? –  Flow Dec 12 '12 at 9:11

17 Answers 17

I had exactly the same problem, then set the power button to end calls. But actually if you go to Dialer(keypad), go to Call Settings and untick "Turn off screen during calls".

It works, as I had this problem since I bought the phone so I think it was set to that as default, because I never even knew how to get in to Call Settings before this problem.

share|improve this answer

There is a diagnostics mode on the Samsung Galaxy S3 - There is a sensor test you can run to make sure nothing is wrong with the proximity sensor. Follow the link Diagnostics mode

share|improve this answer
1  
+1 - nice find. Would you mind pulling some of the essential information from the linked article into your answer for posterity? –  Mr. Buster Feb 15 '13 at 21:27

It could be that the proximity sensor is being turned off.

To keep it on, open the dialer, tap the left button, and press call settings and select the call answering/ending.

share|improve this answer
    
Can you provide a screenshot of that "advanced option"? I cannot find anything like that. Naming the options would be helpful as well, so one could check for similarities. My dialer does not have any "advanced options". –  Izzy Dec 17 '12 at 22:10

You can activate an option in Accessibility Settings that allows you to end the ongoing call by pressing the lock/power button on the side of the phone.

You can test the functionality of your proximity sensor by entering *#*#0588#*#*

share|improve this answer
    
That is dependent on the ROM and may not work across all ROMs... –  t0mm13b Jan 16 '13 at 20:16

I got the same problem with my S3 as well.

The only solution I found is the one above - the lock/power button to hang up. If you go to the phone app you, press menu key (option key the one on the left of the home button the two line button). Then, go to call settings, then call answering/ending, then check the option where it says the power key ends calls. After you check that, you will be able to end calls using the power button.

I hope there's another solution, but this is what I'm using so far. :/

share|improve this answer

It could be that a screen protector is possibly interfering with the proximity sensor. Same thing happened on my old phone.

share|improve this answer

The problem is not just turning off the phone it's putting it on speaker or even getting to the dial pad if you are on the phone with a business. The only fix I finally had to do was make sure that the phone doesn't turn off when its up to my ear.

share|improve this answer

This was happening to me. I found if I put my headset in, the screen would come on then I could hang up the call. I recently changed my screen protector so this may be the culprit. I changed the setting "turn screen off during calls". Hopefully, this all helps since digging for my earpiece is not very convenient.

share|improve this answer

I'm finding I have the same problem. I downloaded an app to test my proximity sensor and found that the sensor works perfectly under bright light, but does not work at all under the normal ambient light indoors.

I believe the proximity sensor actually consists of an emitter and detector. I suspect the emitter is not emitting. Somewhere I saw it suggested that a factory reset might solve the problem. I hate to do that because it means re-installing all apps and contacts. But I guess that's my next move.

share|improve this answer

Clean you screen. I had that problem because of the dirty screen protecting cover. It was blocking the motion sensors, so the phone thought it was at my ear. Once I removed the cover, the phone works just fine.

share|improve this answer

A little late but i have solved the problem by downloading an app called inteliscreen at the google play store . works for almost any android. easy just follow prompts to activate. where it ask for the apps that you want the screen to stay awake make sure you choose the phone app. solved my problem instantly. you can set the app to come on automatically when you boot up your phone. screens stays active during all calls till you turn it off. been searching for months finally found the cure.

share|improve this answer

This is not a fix but it works. While you are on the phone plug it in to a power source and it will wake up and put you back at the unlock screen.

share|improve this answer

I had this issue and found that it was being caused by dust buildup under the glass in the proximity sensor and front camera area. The dust was also affecting the front camera picture quality, you could plainly see the dust covering the inside of the camera lens area.

I completely fixed both problems just with a can of compressed air. I just pulled the back of the phone off and and shot compressed air (using the small straw attachment on the air can) all around the area of the phone. I think the spot that actually got air in there was the tiny noise rejection hole on the top edge. I could visibly see the dust clear away from the camera lens.

Immediately after that the proximity sensor started working perfectly again.

share|improve this answer
    
The compressed air trick completely fixed my problem. I was actually on a phone call (on hold) and having the "black screen" problem while I was reading this post. I removed the back cover and blew all around but the problem continued. I then blew air into the row of small holes at the top on the front of S4 and like magic, it woke up. Thank you Automaticman! PS... I'm still on hold (but at least I can hang up now if I want to :-)) –  user46962 Nov 26 '13 at 15:27

Amazing, but true - use canned air to blow into the ear piece. Dust might have gotten inside the case and be blocking the proximity sensor, causing this behavior. You might even be able to see it with a magnifying glass. I saw this suggestion here - http://forums.androidcentral.com/samsung-galaxy-s4/310276-galaxy-s4-proximity-sensors-activates-but-doesnt-turn-off-2.html and wouldn't have believed it if I hadn't tried it myself and IT WORKED!!

share|improve this answer

My proximity sensor is broken. I spent 10 hours looking for app, which would prevent screen from going black during calls. After 10 hours I found this app, which finally solved my issue:

Proximity AutoLock

I just wanted to share and hope others will find this usefull and won't spend that much time searching as I did.

share|improve this answer

I had the same problem and it ended up being the clear screen protector that came with the otterbox case. I must have improperly installed it.

share|improve this answer

Just try to blow compressed air into the ear piece. Dust is covering the sensor.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.